Showing results for 
Search instead for 
Did you mean: 

Upgraded Computer and One SSD stopped working.

Level 7
Hello. I recently got a new Chassi from a contest and decided it was time to upgrade my computer at the same time. So I bought an Upgrade Package with an:

Asus z790 Hero
Intel i9-13900K
Corsair 32GB DDR5 5600Mzh
WD Black SN850X
Right now I have OS installed on an Legacy SSD Samsung.

The SSD in question is my old PNY CS3040 500GB I had in my old PC which I want to use as my OS Drive. It can appear sometime in Disk Management on the new PC but if I try to format it or delete volumes from it I get prompts is does not exist or is being used by other programs. As I am writing it is not showing up at all, neither in Bios, Diskpart or Disk Management.

When I could see it I could open the drive and look inside it as usual. But right now it doesn't appear at all. I swapped places on my new WD Black and the PNY and it still doesn't appear while the WD works. So I don't think it is the location or the motherboard.

If anyone have an idea or something I would love it. As for now I am confused.

Customer Service Agent
Hello, Wowerus.

Since the PNY CS3040 500GB is not on the ROG MAXIMUS Z790 HERO's QVL list, there might occur compatibility problems.
Please refer to the link below to test if the problem can be solved.

Thank you.