cancel
Showing results for 
Search instead for 
Did you mean: 

Thunderbolt No Longer Working on B550 Pro-Art Creator

darksouls12
Level 8
Hello all,
I have spotted some others with a similar issue after a BIOS update where their Thunderbolt no longer works. I have now tried rolling back to previous drivers without any luck. A reinstall of all drivers and Windows does not yield any results. I do see the Thunderbolt controller in device manager along with the ports in the application. However, no devices such as my UAD Apollo show. I am currently on BIOS version 3002. Support mentioned I have to RMA my board. However, I do not believe this to be the case as I have seen others with a similar issue after BIOS updating. Is there anybody else who may have some insight to this problem?

Thanks so much!
6,522 Views
39 REPLIES 39

Alvez_ROG
Customer Service Agent
Hello
Could you please elaborate on why Thunderbolt cannot be used? Have you tried other devices besides Apollo? Have you ruled out the possibility of wire related?

Hello,
Absolutely. While Thunderbolt shows as working in Device Manager, no devices are detected in the Thunderbolt Software. I have seen the same issue with any other Thunderbolt device such as a dock. However, USB devices do work on the same ports so it is limited to Thunderbolt devices. I have updated all drivers, reinstalled Windows, and rolled back to all previous BIOS versions. I noticed after the "Thunderbolt firmware update" that came with BIOS 3002, I have not seen it run again even when downgrading the BIOS. I have tried 3 different wires as well. It appears there are other users with similar issues on the latest updates. I have linked some of the threads below. While my motherboard is different, it seems to show the same symptoms.

https://rog.asus.com/forum/showthread.php?131615-TB-not-working-after-BOS-upgrade-2204

https://rog.asus.com/forum/showthread.php?132228-Thunderbolt-stopped-working-after-latest-Motherboar...


Let me know if I can answer any other questions.

Thanks!

Jimbo93
Level 12
Just me with a stupid suggestion. What if you tell device manager to show hidden devices and then check for a dead device (grayed out) that might be interfering. Sometimes deleting the grayed out device can allow detection again. But do not delete any devices except for this related to TB.

gzilla76
Level 8
Hi all,

I am also having the same issue as @darksouls12 , with the same B550 Pro-Art Creator board running BIOS upgraded from 2803 to 3302, and can no longer use my UAD Apollo Thunderbolt 2 (with the Apple Thunderbolt 3->2 adapter).

I can still see the Thunderbolt controller in Windows as working successfully, and I have a Belkin Thunderbolt 3 dock and USB-C external disk both of which still connect fine and hot-plug works, so the ports are functional. However, my TB2 UAD Apollo refuses to be detected at all when plugged in, whether at boot time or hot-plug.
I tried connecting the UAD as a chained device through the Belkin dock and into the TB4 port but that also didn't work (other devices plugged into it worked fine). 
I can connect my UAD Apollo to my Mac laptop Thunderbolt port and it works fine there, so no issue with the UAD device itself.

Having read through a few other forum pages I noticed that Intel have decided to nuke Thunderbolt 1/2 devices from their NVM firmware in version 36 and that going back to NVM 31 is where Thunderbolt 1/2 was still working. The 3302 BIOS update upgraded the Thunderbolt NVM firmware as part of its installation, which makes me suspicious this is what broke it. When looking in Windows it shows NVM version 32. I'm not sure if BIOS 2803 had version 31 on it or not.
I haven't tried to roll back BIOS to 2803 yet as I'm worried I'll make things worse until I hear from someone at ASUS.

I think ASUS should at very least make clear on the B550 BIOS page that this update will break Thunderbolt 1/2 connections going forward if that is indeed the intention. I had no prior knowledge this would happen and now I want to get it back and working again.

Is it possible to supply me with a 3302 update that uses the old Thunderbolt NVM v31 firmware, or can I reliably rollback the BIOS and downgrade the NVM firmware on Thunderbolt to make it work again?
I don't like being forced into paper-weighting perfectly usable and crucial devices to my workflow, so I'm hoping it can be restored again with some help please?
 
 

I can confirm again my Apollo Twin X to be working on my B550 creator motherboard with v3002 Bios and NVM v32 for thunderbolt.

Apollo Twinx driver is v18.42.0.397 (latest, march 2023).

uAudio_Creator.jpg

Not sure if it helps, but after flashing a new Bios I do always perform a "load optimized default settings", followed by a "save and exit", then I enter Bios again and reconfigure it.

Thanks for your reply @Flo thats really interesting. I notice you are running a more recent Thunderbolt controller driver there.. I'm on 1.41.1193.0. May I ask where you got the more recent driver from please? Mine is from here: https://www.asus.com/motherboards-components/motherboards/proart/proart-b550-creator/helpdesk_downlo...

I tried doing load optimized default settings in the BIOS, saved and reloaded Windows and it didn't change anything  from my original report sadly. But perhaps the driver difference is what i need?

I did not installed thunderbolt drivers myself, and I didn't installed thunderbolt drivers from Asus support page.

What I did is a fresh Windows Installation and thunderbolt driver was installed automatically as it is included with Windows 11: https://www.catalog.update.microsoft.com/Search.aspx?q=thunderbolt

hmm .. Just checking, is your Apollo Twin X Thunderbolt 3 or 2? My Apollo is TB2 with an TB2->3 adapter.