cancel
Showing results for 
Search instead for 
Did you mean: 

TB not working after BOS upgrade 2204

Hackej
Level 7
Hi!

I have a Z690 Proart Creator WiFi mb connected to a Motu 828ES and a Focusrite 8PreX via Thunderbolt used for music production.
This has been working okay (in Win 10 with BIOS 1720) although quite often with some problems regarding initiation of audio drivers etc.

A couple of days ago I decided to upgrade to BIOS 2204, hoping that TB functionality and stability had improved some, BUT now the audio interfaces are not identified or initiated at all.

Previously it worked if I turned on Motu + Focusrite + computer at the same time, BUT now it doesn't work at all, no matter how I try to start interfaces and computer. The audio interfaces are not recognised or initiated.


- Anyone else experiencing this kind of issue?
I have contacted Tech support regarding this but no reply yet!.

/Hackej
1,295 Views
45 REPLIES 45

Angstromboli
Level 9

I just installed the latest bios 2305 and it fixed the problem, my thunderbolt dock appears to be working correctly 🤗

BUT there might be something you have to do for it to work first. It didn't work immediately after updating the BIOS (same problem as before), and I was seeing an "Error 31" on a device called "PCI Express Upstream Switch Port". So I followed the following guide from Microsoft and tried setting the "HackFlags" registry key to 200: https://learn.microsoft.com/en-us/troubleshoot/windows-client/deployment/error-attach-pci-express-ex...

After doing the registry tweak, everything seems to be good to go. I personally did not need to set it higher to 400 or 600 like the guide says you might.

EDIT: Nevermind, it still isn't working correctly, just a different error now

In mu case changing registry ended up in system recovery TB still not working with new bios 😞

Angstromboli
Level 9

I may have spoken too soon. It seems the "HackFlags" registry fix was only temporary. Now on every startup I'm still having issues. Now though, it's the "Thunderbolt(TM) Controller - 1137" device that is having the error in device manager. It says:

This device cannot find enough free resources that it can use. (Code 12)
If you want to use this device, you will need to disable one of the other devices on this system.


Weirdly, USB 3 devices now show up unlike before. But some of my USB 2.0 devices like my fingerprint sensor are no longer functioning. I have tried changing the HackFlags setting to 600, which the Microsoft article says would address both problems, but it has not.

I also realized this error occurs only when I shutdown the computer fully and turn it back on, but if I restart the computer, the problems go away as well as the error in the device manager. Very frustrating. I have updated to the latest Intel Chipset drivers and Thunderbolt drivers but that didn't help.

Angstromboli
Level 9

FINALLY I was able to figure out a solution, for my case at least. Which was to enable the "ErP Ready" setting under Advanced > APM Configuration. For me the options were "Disabled", "S4+S5", and "S5". I changed it to S5, but I imagine it might work with the S4+S5 option too. I believe S4 allows for hibernating, and I'll explain S5 next.

From my understanding, what enabling this setting and using S5 shutdown does, is make it so when you shut down your computer, it completely shuts down, putting it into a state called S5. Where only a trickle of power goes to the power button and stuff to turn on.  Whereas I guess without it, some stuff still runs in a low power state - I know before, when I "shutdown" the motherboard's OLED and light effects were still going.

In my case, the thunderbolt dock would work fine after a restart, but if I turned on the computer from a "shutdown" state (not S5), it would have the problems. Now, it works both when I restart, and when I turn it on from a full S5 shutdown. So no, this is not a absolute 100% solution if you don't want to keep your computer in S5 vs the other state, but I think it's the best we got so far.

Therefore, my theory is that whatever the problem is, it has to do with the thunderbolt interface coming out of a low power state, and (at least in my case) specifically when a dock was connected and turned on while this occurred. Because for me, if I had the dock powered off while the computer booted from not-S5 shutdown, but turned it on afterwards, it would work. 

 

>> Extra Note: It seems the "Code 31" and "Code 12" errors I was having on some devices in device manager were actually cause by memory issues, and seemed to be separate from the issue I solved above. Basically I have 128GB of RAM and apparently even though I've been using XMP II at 4400 MHz for over a year, with the latest BIOS that was causing instability. So I disabled XMP and then manually set the RAM frequency to 4400 MHz, leaving all the other RAM settings as Auto. After this, the yellow exclamation mark and errors in device manager disappeared. Though the weird problem with the thunderbolt dock not working still persisted, until I found the solution above.

I tried that and it didn't work either.

DezM
Level 8

I am having the same issue with the latest BIOS 2305. And I cannot downgrade the BIOS to older versions. Thunderbolt ports do not appear after a cold boot in Windows 11.  *** for the record, I've tried every single response in this post and others without it working ***

I am having a problem with the Thunderbolt 4 controller when devices are connected during Post and cold boot to Windows. Thunderbolt ports do not appear and are hidden. I have to do a warm boot to get TB to work. So, basically I have to restart twice which is unacceptable.

When the Thunderbolt devices are NOT connected during post, while in Windows the Thunderbolt ports are visible and Thunderbolt devices will work.

Also, if I do a Warm Boot (restart of Windows), the Thunderbolt controller and Thunderbolt devices are visible. I've tried every combination out there to isolate the problem. And I searched for these issues on the ROG forums, as well as Google Search for solutions. I'm confident there is an issue with the newest BIOS.

ProArt Z-690 Creator WiFi
BIOS v2305 (dated 2023/03/22)
Crucial 64GB DDR5 4800 MHz Memory Modules (2 x 32GB). Model CT32G48C40U5 and on QVL and using XMP
Windows 11 Pro v22H3 (Build 22621.1555)
Intel Chipset INF Drivers v10.1.19444.8378
Intel Management Engine (ME) Firmware v16.1.25.2124
Intel Management Engine Interface v2251.4.2.0
Intel Thunderbolt Driver v1.41.1353.0
Intel Thunderbolt Control Center v1.0.36.0

All drivers and firmwares are up to date and latest. Again, Cold boot = no Thunderbolt. Warm boot = Thunderbolt appears. I have a case with Asus but they haven't given me a solution, as of yet.