Showing results for 
Search instead for 
Did you mean: 

STRIX Z690-A GAMING WIFI D4 Sound Issues and BSOD

Level 8
My CPU is a 12700k.

I initially had Win10, it ran ok, no BSOD, and I don't remember crackling audio.

I upgraded to Win11 due to the fact that the cpu scheduler handles the 1700 socket ie 12000 series cpu's better, I had a number of games under Win10 that would peak out only a few cores and leave other unused. I "blamed" the games.
Switching though to Win11 the core / thread balancing is much better, those same games that used to max out certain cores were now more evenly spread and using more cores, great, I thought.

Then I started getting BSOD's: "DRIVER_POWER_STATE_FAILURE"
I did a bit of research, did the usual driver updating etc, the issue persists.
It usually happens right after booting, within 10min, if I can get past the first 10 or 15min then the system is fine.
I used WinDbg and here is the result:
Seems to indicate an issue with audio referring to HDAudBus.sys.

Apart from updating all drivers I also ran SFC /scannow from a privileged cmd prompt, nothing wrong was found.
I am also running in max power mode and I have tried turning off everywhere where it allows the system to suspend or turn off devices.
The issues still stands.

The other issue is crackling audio when using the line out on the back, according to all the results I find I am not alone.
I tried to follow the steps in this thread:
My issue is that the firmware updater "USB Audio FW Update Tool_VID0B05(2021-11-25)_ASUS.exe" does not find my usb audio, even though obviously I have it as it is on and working (apart from the crackling every now and then).
I downloaded that from the support page of my motherboard on the asus site.
It shows the following when run, even in admin mode.

The tool I was using is listed as:
Version -
2021/12/09 3.37 MBytes
ALC4080/ALC4082 audio FW update tool release
Fixed Line Out playing music is noisy

I did perform the following FW update as well:
Version 008
2022/02/25 2.96 MBytes
PD FW update tool
Whether it was successful or not I do not know, it just opened a cmd prompt, flashed a few things then disappeared.

I am running BIOS 1504.
While on the topic of BIOS, I see that some of the prior BIOS changelogs indicate things like...
Update USB PD FW to 1.0F.
Update Intel Microcode
Update Intel ME version

...but 1504 does not, does that mean I jumped over and missed all those intermediary updates? As far as I know the latest BIOS should include all the updates of the prior ones or not?

I'd appreciate some help. All the initial WHEA 17 issues and then BSOD's and Sound crackling has left me a quite bitter with this board and it's far too late to return it, I also spent a lot on this upgrade and will have to keep it a good number of years as I can't afford to just swap it out for something else.

Hi zasy99,

After you installed windows 11, did you install the chipset driver?

Take a look in Device Manager for any missing drivers.

What headset are you using?

Nate152 wrote:
Hi zasy99,

After you installed windows 11, did you install the chipset driver?

Take a look in Device Manager for any missing drivers.

What headset are you using?

I installed all the drivers from Asus.
After the issue started I also installed any newer driver from say Intel.
I also used a driver program called driver booster which found another driver or two that could be updated.
Windows update never suggested any newer drivers.
Device Manager shows everything in the clear.

I am using Creative Gigaworks T20 speakers.
The speakers are fine with other sources.
The crackling can be heard even when doing the speaker test under the sound settings in Windows, if I do the same sound test on say a monitor which is connected via hdmi or dp there is no crackling.

Plugging in or out the speakers to the line out also enables and disables the Realtek USB.
My main concern now is why the FW update utility does not see the soundcard to even attempt to update it.
Then I would like to resolve the BSOD's if that is not solved with the update.
The crackling is my third and last concern.

Thank you for your detailed posts.

I might try reinstalling windows 11.

From the ASUS Support Center, click the link and select Windows 11: -

Install the chipset driver.
Install the Realtek audio driver version 6.3.9600.2295 Under audio, click show all in red to see it. It seems you installed the realtek usb driver.
Install the Bluetooth driver if you use it.
Update the graphics driver.
Update windows.

Then test the audio.

Since you just installed windows, reinstalling should be fairly painless.

Level 8
Ok, I will try with the other audio driver.
I might also try putting windows 10 back on briefly to see if I can use the FW update tool then.
Will report back later when I have finished the various tasks and tests.

As far as I know the new Realtek 4080 audio chipset is attached to the USB subsystem hence why it shows up as that.
The driver I installed is Version 6.3.9600.2307 because it is newer, I believe the misleading part is simply that the title of the old driver is different, the soundcard so to speak is USB, just the naming of the driver package is different.

Unfortunately ASUS is not consistent with their naming convention nor changelog information which is particularly annoying when it comes to BIOS updates.
As I mentioned before in my initial post, well, it was a question, does the latest BIOS update include all previous ones as well as earlier releases mention firmware updates to various devices on the motherboard, not just BIOS but the latest version does not.

Unless I'm overlooking something, you shouldn't need to use the firmware update tool.

The latest bios is its own version. It's good to update to the latest bios, this helps with compatibility and in some instances system performance.

Let me know how it goes after installing/updating what I listed above.

Level 8
I did a restore to Windows 10 before my Windows 11 upgrade (I had done backups with Paragon software).
Here in Win10 it is also listed as a USB soundcard (the 4080 is an internally connected USB 2.0 device) and it is running on Version 6.3.9600.2307 just fine.

I have restarted my PC several times and used it now for a few hours, no BSOD.

The reason I want to use the FW update tool is because others have mentioned it solved the issue for them, why would I not need to use it, the device is not functioning correctly and the tool came out well after the board was manufactured so hence the utility would update the FW on the device in question and potentially resolve my issue.

Also, it should work, whether needed or not, the fact that the tool does not find or list my device is an issue for me, means something is not working.
I tried Win10 and Win11, starting the tool as normal and admin modes, even under safe mode.

This is what you should get (in this demo it is for MSI):
However this is what I get:

If I had a choice I would stick with Windows 10 unfortunately for Intel Alder Lake ie. 12th gen CPU's the Win10 core/thread load balancing is not up to par and often loads less cores to the maximum instead of more cores with less load ie more balanced, I have tested this myself with games under win10 and win11.

I might try another fresh install of Win11 again later however the fact that I cannot even update the FW on the soundcard with the tool directly from Asus is rather annoying, others have been able to do this as demonstrated in the reddit thread and also on other boards as in that video I linked above.

Level 8
Update: Interesting, in regards to the FW update tool, I got distracted by somebody in the house, went away for about 20+min and came back and now all the fields are populated and I can hit "start", now it's updated.

I will now try and re-install Win11 soon and report back.


Level 8
After the new Win11 installation and FW update to the Soundcard the sound is better now.
I thought I was in the clear but even as I was writing this reply I had a BSOD and the PC restarted so here I am writing this a second time.

I don't understand what it could be as I have all the latest PD, ME, Soundcard firmware and latest main BIOS, I have all the latest drivers and windows updates.

I am going to perform a few extra steps mentioned by a user MoKiChU to see if I can get a more stable system, if not then I am really at a loss.