Showing results for 
Search instead for 
Did you mean: 

ROG Strix z690A Gaming WiFi WHEa 17 Errors

Level 7
Swapped my fully functioning 3090RTX, 9900K, Z390 Gigabyte Designare setup for a brand new Z690 and 12900K rig.

After swapping all components over to the Gaming Wifi MOBO and 12900k combo, install WIN 11 and I get thousands of WHEA errors for ven_8086&dev_ 460d&SUBSYS_86941043&REV_02

I also get random hangup, BSODS, and straight crashes.

I'm a day of frustration away from RMA. I swapped back to old system and all works perfectly with 9900k and Z390 mobo, so the only possible hardware issue is the mobo or CPU....I guessing this is a mobo hardware component issue.

PCI ID Repository suggests it is a 12th Gen Core Processor PCI Express x16 Controller #1.

Device manager showed no issues with any hardware.
333 REPLIES 333

Customer Service Agent
Hello, philsrb and sorry for any inconvenience this may cause.

Could you help to confirm the question below for better undetstanding the sanario of the problem?
- the full model name of your motherboard
- the serial numbers of your motherboard via pm
- the current BIOS version and the content of the setting in BIOS (or whether it is the default)
- the brand and model name of the CPU, DRAM, GPU, and PSU currently installed
- the OS version and OS build

Thank you.
sharing complete hardware info & software config details will help us better understand the issue 🙂

Level 9

Really wish I had looked at the Z600/Z700 boards a little closer from Asus. 3/4 kits of RAM were 'defective' while testing out my Z690 Maximus Extreme, lots of issues with xmp/ram, random crashes. Now every so often my main monitor "blinks" and Event Viewer displays the same error OP is having, WHEA 17 on PICE Express port.

Haven't hit my anniversary with this board and with this being the most issues I've had putting together a computer, I think this board will become the one I keep the shortest. Really regret giving Asus a try. Forgive me Gigabyte 😓

Level 7

This issue started to come up for me on the last 2 days. I was like maybe it's the bios 2305 so I reverted back to 2204 and I am still getting the same issue. This has never happened since owning the board back in February 2022. The only hardware change I've made on my system is I replaced an ADATA SX8200 Pro with a WD SN850X on the same M.2 slot. Is there a known fix for this issue at this time?

enable Native ASPM in the bios, and turn off PEG ASPM, and PCIE Clock Gating.

The developer of HWinfo64 has assisted me in arrowing down this issue by the use of the HWinfo64 debugger and it points to the SN850X. Is there a way we can bring this to Asus's attention for a fix?

For anyone else experiencing WHEA-Logger 17 errors, doing this suggestion has stopped the errors from constantly appearing in Event Viewer.

Doing what?

Well, I was talking about the message I replied to not sure why it doesn't auto quote it.

I did this in my BIOS, "enable Native ASPM in the bios, and turn off PEG ASPM, and PCIE Clock Gating."

Prior to it, my system was stable so the only thing in Event Viewer was tons of WHEA-Logger errors and my main monitor would constantly turn off/on as if I just plugged it in or connected it to GPU.


After doing those suggested steps, I have zero WHEA-Logger 17 errors and my main monitor hasn't cycled once. It's only been a day or two since I enabled the settings but it's much better.

Ive tried that and it doesnt work for me. 

Level 7

My z690i is getting WHEA-Logger 17 warnings. The system is stable and I haven't had any issues. Just the event viewer shows these warning frequently.  Is there a reason to be concerned if the system is stable?