cancel
Showing results for 
Search instead for 
Did you mean: 

Rog maximus z690 extreme new build - won't post

KilROCK
Level 7
New build and I can't get it to post. Q-Code halts on 55. I've tried 2 different brands of DDR5 - ADATA XPG Lancer 41600 and TeamGroup Elite DDR5 4800 - I've tried sticks one at a time and 2 sticks at a time - I have not mixed the brands together.

I've reseated my CPU several times along with the cooler but no difference. If I try to post with no sticks it will hang on Q-Code 53. I have not been able to get into the bios using my 3090 or by using the onboard video.

Is this related to the Z690 Hero boards that are faulty since the orange LED stays on?
5,647 Views
13 REPLIES 13

theroc44
Level 9
yeah I second what everyone said, If you have the ram in the wrong slots it will not post. If you look at the extreme z690 board straight on, its the second and fourth slots.91518

theroc44 wrote:
yeah I second what everyone said, If you have the ram in the wrong slots it will not post. If you look at the extreme z690 board straight on, its the second and fourth slots.91518


Tried all combinations of ram slots, love the picture though

theroc44
Level 9
did you switch to the other bios, same results?

thomas_yiu
Level 9
please troubleshoot:
1. Confirm that the memory is fully installed as shown
2. Check if there is any dirt on the memory Pin or memory slot of Motherboard
3. Please replace your DRAM with the one on Memory support list(QVL list)
4. Please refer to the suggested memory configurations found in the user manual of your model as shown in the below picture, then try again.

You can refer to download user manual
5. If you're using two or more memory, try to boot with only one memory installed, then reboot each time with an additional memory installed.
6.If your problem cannot be solved after following steps 1-5, please change the memory and try again
7. If above setups still cannot solve your problem, please reinstall CPU or change another CPU
Sincerely,
TY