cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Flow X13 keyboard backlight and fn/media keys no longer working

waitcommawhat
Level 7
Exact model is Asus ROG Flow X13 GV301QH-K6200T, with Windows 10.

I'd been playing Subnautica (highly recommend!) for a couple of hours then when it was time to go to bed, I noticed a Windows Update was waiting. Chose "Update & Shut Down" as I was going to bed, noticed it said "Restarting" instead of the expected "shutting down", but after a couple of minutes it did shut down and I thought nothing more of it. Turned it on the next morning.... no keyboard backlight or FN/Media keys.

It's not all fn keys that aren't working, just the ones on F1-F12 - keyboard brightness, screen brightness, etc. The fn commands on the arrow keys - page up/down, home, end - all work fine. And I'm 99.9% sure the problem is software/firmware as the keyboard backlight flashes on boot.

I have tried:

Restarting
Flipping between laptop/tablet mode and back again (as the keyboard is not active in tablet mode, thought maybe that could jumpstart the keyboard)
Uninstalling the Windows update
The Windows Keyboard troubleshooter - no problems found
The MyAsus One Click Diagnosis tool - no problems found
In Device Manager, clicking "update driver" on anything that seems relevant - everything is already at the most up-to-date version

None of these have helped.

I then tried a complete factory reset, for a completely fresh Windows install. Didn't help. Let all Windows/Asus updates happen - including the ROG Firmware Update Tool V2.1.0.001 & ROG Keyboard Firmware Update Tool V2.7.0.003 - still hasn't helped!

I know the next step is to re-install the drivers for the keyboard... but I can't find them on the downloads for this laptop model, the only download available that mentions keyboard is the Hotfix V2.6.0.001, that is for "This app updated keyboard's firmware to fix LED lighting issues."

Downloaded, installed, no change.

Can anyone point me to the drivers for my laptop, or advise what else I should do to get the backlightlight and keys working again? I'm at the end of my tether now, I'm normally pretty good at fixing PCs but this has me stumped.

Thanks in advance!
2,327 Views
4 REPLIES 4

STARRAIN_ROG
Customer Service Agent
Hi waitcommawhat,
Are the upper volume key, mute key and ROG key working fine?
May I have the bios version?
Please refer to the following link to do the suggestions.
https://www.asus.com/support/faq/1044851
- EC reset
- restore bios to all default settings
- make sure bios and windows packages all up to date
- reinstall ASUS System Control Interface V3.0.13.10 from our support site.
https://rog.asus.com/laptops/rog-series/2021-rog-flow-x13-series/helpdesk_download
Thank you.

Hi STARRAIN@ROG,

Thank you so much for your help.

Upper volume keys, mute, and ROG button do not work either - are they separate to the fn keys?

Bios version is - BIOS Version/Date American Megatrends International, LLC. GV301QH.407, 31/05/2021

I have tried the EC Reset & unintstalling/reinstalling Asus System Control Interface, neither has helped. I will try updating/resetting the Bios at the weekend when I have more time.

STARRAIN_ROG
Customer Service Agent
Hi waitcommawhat,
If you only press F1-F12 key(without FN key), do they work in bios and in browser? (There are some function key shortcut in some apps.)
If they work in bios but don't work in browser, please enter safe mode and check again.
https://www.asus.com/support/FAQ/1013018/
If they work in bios and in browser, please restore bios to all default settings and then run windows update again when you have more time.
Thank you.

HERONANA
Level 8

I have faced the same issue a couple of days ago, and the fix was relatively easy:

1. (not sure if necessary) uninstall ASUS System Control Interface v3 from device manager.
2. (maybe this isn't necessary as well) reinstall it from device manager.
3. update it to an older version that's located on the system through device manager.

After that everything works just like it's supposed to, hope this helps!