Showing results for 
Search instead for 
Did you mean: 

ROG Claymore II: Certain keys not working.

Level 7
Hi there.

I'm not sure if my keyboard received some damage recently after I swapped my room around, but ever since I reconnected everything to my pc, the whole 2 middle rows of keys have stopped working from q and a to enter.

I have tried resetting the keyboard and un/reinstalling the drivers but this does nothing and have also found that these keys will only work if I press them alongside the key directly above it.

I am unsure how this started and curious to know if it has been damaged or some kind of fault has occurred.

Any advice would be great.

Hello dazzyboy10

Welcome to the ROG forum.

Just to confirm, you reset your ROG Claymore II by pressing and holding the Fn + ESC keys for 10-15 seconds.

Have you installed Armoury Crate and checked for updates at the update center?

Have you tried the USB-C to USB-A adapter cable?

The latest version of Armoury Crate is

Click the pic to make it bigger.



I have the exact same issue but it happened without any damage on the keyboard , from one day to another the two lines of keys where Q and A are are not working anymore, unless you press the below or upper key together with the other one.

For example I can't press q but when I press together q and a I optain : qa

Same for ws ed rf tg zh uj ect.. and since few days when I press ENTER it gives : $ then ENTER

I purchased this keyboard in Philippines one year and 3 months ago and in Philippines there is only 1 year of warranty for some reason.. quite frustrating..

I have tried everything, WIFI dongle , USB-C , USB convertor, etc...

Last firmware update too and Armoury crate is up-to-date.

If it's a software/driver issue I would appreciate a workaround or a fix.

Best regards

Happening the Same for me. I have ZephyruS M16 GU603HR-K8093T and a bunch of keyS are not working properly. Tried to uninstall the keyboard and nothing. Right now for me to use a key that is not working i need to preSS a combination of Shift + S to make it work.


le1: tried to check if the Same iSSue appearS in bioS and the anSwer iS yeS.

le2: for some reason, I was trying to chat to amazon support (from where I bought the laptop) and now all of the sudden, my keyboard is working. I don't understand the issue/problem

le3: went in Sleep mode and not working again


Hello Nate152,

Yes indeed I tried to reset the keyboard , several times with no luck.

My ROG Claymore II being a Wireless keyboard I tried to power it ON without plugging it to the computer and tried to test keys with a light profile that should light the keys when pressed. Therfore I can tell it's not a driver issue but something went wrong in the electronic of the keyboard.

I've tried also to connect it to an android device and have the exact same issues.

I also noticed that the letter k need to be press "harder" for it to work and pressing k and i doesn't work in the same way it does with the previous letters on the same line of keys.

I run out of ideas...

Best regards

Hello M1r007 and acustiko

Welcome to the ROG forum.

Try resetting your ROG Claymore II by pressing and holding the Fn + ESC keys for 10-15 seconds.

For a laptop I will suggest performing a system recovery.


Exact same issue for me on my second Claymore keyboard - the Red one (

Anyone found a solution ? I would prefer to avoid sending it back for replacement (the retailer has no more stock so they will just refund it to me...)

Try using the Armoury Crate uninstall tool and reinstalling Armoury Crate version

From the ASUS Support Center, select your operating system and click Show all in blue, the Armoury Crate uninstall tool is the third download.

If resetting your keyboard and reinstalling Armoury Crate using the uninstall tool doesn't help, I'll suggest to contact ASUS Tech Support for your region.

Level 7
Hi dear Asus team,

I'm typing now with my keyboard and it's working almost ok, only few things are not working like for exemple le fn key and therefore I can't reset the keyboard or change color profile.

But I found the cause of my issue of keys that doesn't work and here is a picture of why :
As my warranty is already finnished ()since 3 months, I decided to open the keyboard and find out that the batterie has swollen a fair amount and this was pushing on the circuit board as it has bended the metalic enclosure.

So I removed the battery completely from the keyboard and connected back the side connector for the numpad and screw all back in.
I can see now the two lines that were previously not functional are working perfectly fine.
The only issue I have is the Fn is not working at all and also the dollar key , up to enter, doesn't work as well.
All the reste seems functional.

I would appreciate if possible that an engineer could contact me on my email to explain how I can fix this, I openned a ticket but the answer I get is allways the same, try to update Armoury crate , or go to see your dealer , which obviously will not work as my device is not under warranty anymore.

Thanks to have taken the time to read my post.

Best regards


Very interesting finding M1r077. Mine is still under warranty so I will not try opening it...

I just received the refund for my first defective Claymore (Fn and a couple of other keys not working) and I was wondering which new keyboard I should buy. If the Claymore batteries are proven to be defective, I will definitely not buy the same again 😞

Can anyone from Asus give information about this ? Batteries being so badly swollen after 1y of use is not really expected