Showing results for 
Search instead for 
Did you mean: 

ROG Claymore II: Certain keys not working.

Level 7
Hi there.

I'm not sure if my keyboard received some damage recently after I swapped my room around, but ever since I reconnected everything to my pc, the whole 2 middle rows of keys have stopped working from q and a to enter.

I have tried resetting the keyboard and un/reinstalling the drivers but this does nothing and have also found that these keys will only work if I press them alongside the key directly above it.

I am unsure how this started and curious to know if it has been damaged or some kind of fault has occurred.

Any advice would be great.

I am having this issue now, two lines stopped working! I am going to be brutally honest, I am ver disappointed with several things in Asus ROG products.
250e keyboard with a swollen battery that might explode at any second.
Armory Crate software that never work as it should just like Aura Sync or Armoury
I had to change sever headsets because one ear stop working.
Before I bought everything from Asus but sadly won't do it again

Just wanted to reply here to say I recently experienced exactly the same thing. At first my 'o' key stopped working intermittently, and about a week later the QWERTY... and ASDFGH... rows stopped working entirely, *except* if I pressed Q and A simultaneously, or W and S simultaneously, etc. At first I thought it was a software/driver problem, but I verified the same problem by setting the LED effects to make the keys glow when you press them and testing when not connected to the computer. The problem remained.

I still thought it must have been a software/firmware problem, since pressing Q and A simultaneously worked fine, so I thought maybe I could hard reset the on-board software/firmware by completely running the battery down, so I left the keyboard unplugged for about a week until the red low-battery light wouldn't even light up anymore. But after plugging it back in, the problem still remained.

I was still thinking that it was a software problem, but perhaps there was some on-board memory being retained by a coin-cell battery or something, so I followed some youtube instructions to find the screws to open the keyboard. After removing the appropriate keycaps and starting to unscrew the screws, I noticed the screws were very tight and the plastic keyboard frame was audibly releasing as if it was relieving some kind of pressure. Upon removing about half of the screws, I noticed the keyboard was starting to spin on my desk (i.e. the rubber corners were no longer making contact with the desk), and there was an obvious 'bulge' underneath. Finally after removing all of the screws the plastic frame easily came apart and I was able to lift up the circuitboard and see the metal container for the battery, which was already visibly bulging. Upon removing the metal container this was my battery:


I consider myself "lucky" that I accidentally discovered this, since who knows when it would explode? Personally I don't use the keyboard itself wirelessly, it's always plugged in, so I simply detached the battery from the circuitboard and put the keyboard back together. The keyboard works fine again (without the battery), except for two critical features:

1. The USB passthrough doesn't work. I usually use the USB passthrough to charge and use my ROG mouse when its battery is low, but the USB-A port on the back of the keyboard doesn't work anymore.

2. Macros are forgotten as soon as I power off the computer (since it also removes power to the keyboard). Clearly the the on-board battery was responsible for keeping macros/keyboard settings intact, but without the battery the keyboard resets to factory defaults whenever the USB power turns off.

M1r077 wrote:
Hi dear Asus team,

I'm typing now with my keyboard and it's working almost ok, only few things are not working like for exemple le fn key and therefore I can't reset the keyboard or change color profile.

But I found the cause of my issue of keys that doesn't work and here is a picture of why :
As my warranty is already finnished ()since 3 months, I decided to open the keyboard and find out that the batterie has swollen a fair amount and this was pushing on the circuit board as it has bended the metalic enclosure.

So I removed the battery completely from the keyboard and connected back the side connector for the numpad and screw all back in.
I can see now the two lines that were previously not functional are working perfectly fine.
The only issue I have is the Fn is not working at all and also the dollar key , up to enter, doesn't work as well.
All the reste seems functional.

I would appreciate if possible that an engineer could contact me on my email to explain how I can fix this, I openned a ticket but the answer I get is allways the same, try to update Armoury crate , or go to see your dealer , which obviously will not work as my device is not under warranty anymore.

Thanks to have taken the time to read my post.

Best regards


Identifier wrote:
Just wanted to reply here to say I recently experienced exactly the same thing. At first my 'o' key stopped working intermittently,f.

I had the same issue where the "o" stopped working, followed what you did and removed the battery and voila everything now works. Downside is it's now a wired keyboard.

this is very true, my unit as well did not work and notice a bulge at the back of the keyboard. since its already out of warranty, I opened the keyboard and the battery is swollen, causing some kind of pressure to the keys that were malfunctioning.

i pulled out the battery and got the part number C11P707. good thing it is quite a common battery used by ASUS on their phones. already ordered one, hopefully, the keyboard will work as it used to be (wireless) when the part arrives. for now its working perfectly fine as a wired one.


Level 12
Hi feuxeu77,
Do you see any bulge from the keyboard surface?
If it is under warranty, please send it to RMA for further examination.
Thank you.

Level 7
Hi Starrain

After checking, yes, there is a clear bulge underneath the keyboard. Not sure it's so clear on the attached picture but it's there.

Unfortunately Asus Service Center in Thailand doesn't want to take care of this keyboard so I will just return it to the shop for refund (warranty provided by the shop). Not sure it will get any further examination.

What I can say is that I used my 2 keyboards in Wired mode. I used the wireless mode only from time to time.

Yes we can clearly see a bulge. And this is in the exact spot where the battery is located.

feuxeu77 wrote:
What I can say is that I used my 2 keyboards in Wired mode. I used the wireless mode only from time to time.

Same here I don't really use the WIFI mode that often, only when updating firmware actually.

What I noticed after having removed the battery is that I receive sometimes a message from my system that the USB device is pulling too much power from the USB port (USB power surge).
I may try to open it again and isolate the end of the power cable that was connecting the battery.

I openned a ticket with Asus and did receive a mail from the local Service center in Philippines and, as expected they told me that they don't have the spare part or the will to do anything about my issue. I will bring it back to Switzerland and try to make it work myself.

I still would be gratefull is some Asus engineer could guide me on how to achieve that.

Best regards


Level 12
Hi feuxeu77,
I'm afraid the service type in some countries should be through the retailer/dealer, so it is proper to contact the shop to claim warranty.
Thank you.

Hello, Identifier.

We apologize for any inconvenience this may cause.
Please note that disassembling the device may lead to a loss of warranty.
Based on the situation you describe, it is recommended that you visit the ASUS Repair Center to have your device checked.
Please refer to the following link for further assistance.

Thank you.