cancel
Showing results for 
Search instead for 
Did you mean: 

Please re-add support for proper Hardware Sleep S3 on new Laptops

garlicbready
Level 7
Hi,
so this is a follow up to a previous post I made about getting sleep to work on my new Asus ROG Latop
https://rog.asus.com/forum/showthread.php?126967-Laptop-GX703HS-KF075T-Sleep-Mode-Issues&p=856491#po...

From what I can tell the new way of sleeping a laptop is to avoid the use of S3 hardware sleep states
and to instead sleep the laptop in S0 mode using something called "modern-standby"

What this does in short is still keep the laptop running but make it look like it's sleeping.
I've had other issues with this so far, this may be related to the mouse sleep issue (which is kind of ridiculous that this even passed Quality Checks)

  • Sometimes takes a long while to actually go to sleep
    it might be a bit of random software running in the background stalling out the sleep process
    with the only way to fix it by forcing a reboot which sort of defeats the point.
  • The fingerprint reader sometimes stops working after 3 or so sleeps, forcing the use of the pin number
  • Bluetooth seems to be still active even when sleeping (headphones still connect)
  • Power draw is higher / battery doesn't last as long


Personally I wouldn't trust putting this in a bag closed up while in this state
Carrying this laptop around would mean definitely shutting it down which sort of defeats the whole point to be honest

Overriding / Setting Sleep to use S3

Now there is a way to force the use of the S3 mode by setting a registry key of PlatformAoAcOverride

https://www.reddit.com/r/ASUS/comments/puw6j9/finally_a_fix_for_modern_standby_s0_sleep/

reg add HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride /t REG_DWORD /d 0


This seems to partially work, the laptop goes to sleep a lot quicker than before
The mouse turns off (yay that finally works)
Power usage is a lot less
The led's cycle on the keyboard indicating it is actually in sleep mode
It doesn't wake from sleep using the finger print reader but I could live with that, pressing a key triggers the wake anyway

However there is a big problem in that when waking from sleep something causes a crash / forces a power cycle.
The 3 led's go off then the bootup logo comes on with errors of an improper shutdown in the event logs.

Based on reddit threads this seems to work on older models of laptop where they've tried to force the use of "modern standby"
But not the most recent ones.
I suspect in my case it might be the use of Raid0 SSD's that might be causing problems

Please Please fix this, as "modern standby" is just too buggy at this stage.
I suspect a lot of modern peripherals such as usb devices are not designed to work with it
1,082 Views
4 REPLIES 4

garlicbready
Level 7
Looks like I'm not the only one
https://therightstuff.medium.com/an-investigation-into-my-new-laptops-stubborn-refusal-to-sleep-8575...

Looks like a general Microsoft issue trying to force a new standard onto everyone that doesn't work.
I've also seen threads with Dell laptops having similar issues.

Any fix for that?

If one uses AMD, it could work with this solution:
https://www.elevenforum.com/t/does-s3-sleep-work-in-windows-11.2216/post-258516

It worked for me regarding my ASUS ROG Strix with AMD Ryzen 9.

Asus, you have been a great laptop manufacturer until you removed S3 sleep from 99% of your new laptops. Intel's fault I know, but it's not that hard to re-add it to BIOS! You've updated many things in BIOS why can't you add S3 back?