cancel
Showing results for 
Search instead for 
Did you mean: 

PCIe Speed Z690 Extreme

sempix
Level 7
Hello,
I am a 3d artist and i have a system with a 13900k and 2 GPUs on an Asus Maximus z690 Extreme motherboard. One GPU is an RTX4090, the other is a 2080ti. Now the theory is that both GPUs should be running at 8x speed. Both the bios and GPU-Z only show a speed of 4x for the second PCI slot. I have already swapped the positions of the graphics cards. However, the lower slot always remains at 4x speed. I have the M2_2 and M2_3 occupied with an SSD, all other slots are free. Does anyone have an idea how I can bring the speed of the second pcie slot to 8x?
1,548 Views
17 REPLIES 17

Jiaszzz_ROG
Customer Service Agent
Hello, sempix.

Although according to page 1-7 of the English version of the user manual, when you install Dual VGA, both should run at x8 speed, but checking page 1-11, M.2_1 shares bandwidth with PCIEX16(G5 )_2. When M.2_1 is enabled, PCIEX16 (G5)_2 will be disabled.
Therefore, it is recommended that you refer to the user manual via the link below to first confirm whether your two SSDs occupy M.2_1 instead of M.2_2 or M.2_3.
https://rog.asus.com/motherboards/rog-maximus/rog-maximus-z690-extreme-model/helpdesk_manual/

Meanwhile, could you please provide your current BIOS version and the BIOS settings you have adjusted?
Please try defult the BIOS setting to see if the poblem able to solve as well.

Thank you.
Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Good morning,
yes, as I have already written, the M_2.1 is not occupied. I have already also installed the latest Bios 2204 and made a CMOS reset. Unfortunately all without success. What is especially strange is that when I boot the pc in the off state, it shows me in bios a pcie speed of 8x of the second slot. The 2nd graphics card is then but not recognized by Windows. If I then restart the PC is detected in the bios again 4x and the GPU is available in Windows.

Has no one an idea? Do you think the motherboard is broken? I would swap it for the Z790 Extreme, but unfortunately it is no longer available.

Jiaszzz_ROG
Customer Service Agent
Hello, sempix.

Could you share the following information?
- the brand and model name of the DRAM, GPU, and PSU currently installed
- the serial numbers of your motherboard and GPU via pm
- the OS version and OS build
I will attempt to look through your configuration to see if there's anything there that could help.

Thank you.
Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Hello, thank you for your reply. I sent you a PM with the serial of the mainboard. Here's my configuration:

Power supply: 1600W Seasonic Prime TX 1600 80+ Platinum
Mainboard: MB S-1700 Z690 ASUS ROG MAXIMUS Z690 EXTREME
CPU: INTEL S-1700 i9-13900K Tray 1 St
Ram: 128GB: G.Skill Flare X5 - DDR5 - Kit - 64 GB: 2 x 32 GB 2 G.Skill Flare X5 - DDR5 - Kit - 64 GB: 2 x 32 GB - DIMM 288-PIN Low
Profile - 5200 MHz / PC5-41600 - CL36 - 1.25 V - ungepuffert - non-ECC
GPU: 2x inno3D 4090 X3 OC
SSD: M.2 2000GB Samsung 980 PRO NVMe™ M.2 PCIe® (in M2.2 and M2.3)
OS: Microsoft Windows 11 Pro 64Bit SBV DVD

Jiaszzz_ROG
Customer Service Agent
Hello, sempix

Thank you for sharing the information.
Could you help confirm if you have also updated the Intel Management Engine to the latest version, 16.1.25.2020, before updating the BIOS?
If so, please also provide an image of the BIOS main page and the ME firmware version.

Meanwhile, may I know if it will be able to run in X8 if you only install one GPU in the PCIEX16 (G5)_2 slot?


Thank you.
Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Hi, please find the following images showing my installed versions. I'm in a production process at the moment, but will check it soon, if the slot runs with 8x if only one ssd is installed 9766297663

Hi Jiazz,
i tested it with only one ssd installed in Slot M2.2. Unfortunately same problem here. BTW seems like this problem exists for a longer time:
https://linustechtips.com/topic/1400508-dual-gpus-on-asus-z690-maximus-extreme/

Jiaszzz_ROG
Customer Service Agent
Hello, sempix.

Could you please help confirm that will it be able to run in X8 if you only install one GPU in the PCIEX16 (G5)_2 slot?

Thank you.
Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂