cancel
Showing results for 
Search instead for 
Did you mean: 

PCIe Slots missing Maximus X Formula

MaxHunter
Level 7
After installing a 3090 I decided to unplug everything and clean the fans, and case, etc. During this time I decided to plug a minimal amount of components back in/on, but suddenly it doesn't recognize any of the PCIe Slots?路 The GPU works (so not gpu,) the igpu works (so I'm assuming it's not a motherboard issue,) the lights are on both motherboard and 3090 (so not a psu or cable issue,) but won't recognize any of the slots in the bios. Bios has been updated to 2.7 successfully. Am I missing something? A step perhaps? Is there a bios setting I should double check? Can not having a certain component like a fan or data, etc cause this issue?

Jays2cents suggests it's an issue with displayid in the vbios, but I can't understand how the vbios on a gou can cause the motherboard not to recognize any pcie slot.

Thoughts?
672 Views
3 REPLIES 3

xeromist
Moderator
If you haven't already make sure you reset to defaults in the BIOS. But since this happened during maintenance I'd suggest tearing everything down and starting over because something might not be seated correctly. Also, if you did anything with the CPU I would pull it out and inspect the socket for bent pins.

If you do have iGPU working then have you tried running the system without the 3090? Does that make any difference?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

MaxHunter
Level 7
Thanks for your suggestions:)

I have:
Cleared CMOS, to include removing battery over night, holding power button and manually pressing CMOS button for 30 seconds.
I've checked every pcie with three different GPUs (3090, 3080 ti, and a 1080) and a USB card.
I didn't touch the CPU (I didn't want the hassle 😆)
I've tried different psus and cables, and waiting on a new cable set just to be sure.

Ugh! This is so frustrating because I'm not definite, but pretty sure nothing is broken or burned out because lights are on on the GPU, and the igpu works fine.

Jiaszzz_ROG
Customer Service Agent
Hello, MaxHunter.

May I ask if there is no selection in the PCI Express configuration in the BIOS? Are any of the ASUS Q-LEDs on?
Does the BIOS not recognize PCIe after you update the BIOS? Or does it only happen after you unplug everything?
Could you provide the BIOS version and a screenshot of the unrecognizing issue so we can better understand the problem?

Please refer to the link below and test with minimal components, isolating the possible cause.
https://www.asus.com/support/FAQ/1042632/

Thank you.
sharing complete hardware info & software config details will help us better understand the issue 🙂