cancel
Showing results for 
Search instead for 
Did you mean: 

PCIE problem with 2 card

tifo71
Level 7
Hello all,

Motherboard ASUS TUF B550plus
CPU : Ryzen 9 5900x
Sound Card : Creative Sound Blaster X AE 5 plus

I have a problem i have Sound card connected in PCIE x16_2 and usb3 PCIE card in x1_3 and my sound card don't work
but when i remove usb 3 card in pcie x1_3 and i leave sound card. My sound card works
but 2 card connected in 16_2 and 1x_2 orr 1x_3 don't work
do you have same problem ?

Bios updated and chipset drivers too.

do you have idea for fix this problem ?

Thanks for your help
1,936 Views
10 REPLIES 10

RedSector73
Level 12
There was a problem a while ago where 10 Bit Tag support needed to be disabled to get the add-in sound card (such as SB) working, but I thought this was fixed with AGESA updates. You could try disable it and see if it works. I would have thought SB and AMD would have addressed this by now.

RedSector73 wrote:
There was a problem a while ago where 10 Bit Tag support needed to be disabled to get the add-in sound card (such as SB) working, but I thought this was fixed with AGESA updates. You could try disable it and see if it works. I would have thought SB and AMD would have addressed this by now.


Hello, i have disabled ten bit tag support but nothing change. there is a problem between x16_2 x1_2 and x1_3 when 2 cards is connected. i retry to connect my USB 3 card in 1x_3 but same problem my SoundBlaster X AE5 plus don't work and when i disconnect my USB3 cards My sound card works.

I have write to amd and according to them it is a problem of motherboard it is necessary to contact ASUS. Thing I did and I am waiting for news from ASUS.

it's very strange. At this point AMD chipset Sucks. Intel have a better compatibility with chipset and PCIE lines.

it's not complicated, I'm sure it can be resolved with an agesa update or bios update only

STARRAIN_ROG
Customer Service Agent
Hi tifo71,

Please refer to our manual for the information below.
PCIE 3.0 X16_2 runs x1 mode when any of the PCIe 3.0 x1 slots is occupied.
https://dlcdnets.asus.com/pub/ASUS/mb/SocketAM4/TUF_GAMING_B550-PLUS/E16576_TUF_GAMING_B550-PLUS_UM_...
Please consult Creative will the sound card work properly if it runs x1 mode.
Thank you.

STARRAIN@ROG wrote:
Hi tifo71,

Please refer to our manual for the information below.
PCIE 3.0 X16_2 runs x1 mode when any of the PCIe 3.0 x1 slots is occupied.
https://dlcdnets.asus.com/pub/ASUS/mb/SocketAM4/TUF_GAMING_B550-PLUS/E16576_TUF_GAMING_B550-PLUS_UM_...
Please consult Creative will the sound card work properly if it runs x1 mode.
Thank you.


Then can't we connect two cards ? Creative card can work in x1. The problem is the B550plus not the sound card.
with my previous motherboard X470 prime pro have no problem with 2 cards

STARRAIN_ROG
Customer Service Agent
Hi tifo71,

May double check not working means the sound card didn't appear in the device manager?
Have you restored bios to all default settings, updated bios 2423 and AMD Chipset Driver V2.11.26.106, and it was the same?
May I have the informations below?
-the serial number of your motherboard(via pm)
-the brand and the model name of your ram(such as Hyper X HX446C19PB3K2/16), vga, psu and ther PCIE components
Thank you.

STARRAIN@ROG wrote:
Hi tifo71,

May double check not working means the sound card didn't appear in the device manager?
Have you restored bios to all default settings, updated bios 2423 and AMD Chipset Driver V2.11.26.106, and it was the same?
May I have the informations below?
-the serial number of your motherboard(via pm)
-the brand and the model name of your ram(such as Hyper X HX446C19PB3K2/16), vga, psu and ther PCIE components
Thank you.


Hello, i have send PM with information that you ask me. thanks

STARRAIN_ROG
Customer Service Agent
Hi tifo71,

I'm sorry I have some questions about the description in PM.
Please check PM again. Thank you.

STARRAIN@ROG wrote:
Hi tifo71,

I'm sorry I have some questions about the description in PM.
Please check PM again. Thank you.


Yes thanks i have reply to your PM thanks for your help

STARRAIN_ROG
Customer Service Agent
Hi tifo71,
Thank you for your reply.
I'll consult our technical team about this.