Showing results for 
Search instead for 
Did you mean: 

Issues with ASUS ROG Swift PG279QM

Level 7

I have 2 issues with my monitor, that I have been scratching my head on/off to find a solution for the past few weeks, without any luck.
First of all, the monitor is a ASUS ROG Swift PG279QM QHD 240Hz, bought around ½ months ago +-.

Issue 1:
ECO mode keeps turning back on, every time the monitor is turned on. This has been an issue from the start, but after tweaking a few different things, i managed to fix this, ealier this year, not sure what made it not switch back tough.
The issue has since returned after a recent power outage. Any tips/solutions for a permanent fix to this?

Issue 2:
After the recent power outage, the monitor has been unable to go above 120 Htz. If put above, it simply goes black and a message about missing signal on Displayport appears.
The only solutions i have been able to find for this issue, has either been to use the original display port cable to connect between pc and monitor, or to try and take the power cord out of the monitor for a while. None of these have solved the problem so far (I have been using the original cable since i bought the monitor,).

I have attacted a picture of the current settings in Nvidia Control Panel, in case this is relevant:

Any help / tips is highly appriciated! 😉

You could try changing the Output color format to something less bandwidth intensive like YCbCr422 and see if that allows you to go above 120. That might tell you if it's just a raw bandwidth limitation. On that topic, it's possible to get a faulty cable in the box that can't achieve max transfer speeds so if you have any other DP cables it would be worth trying them.

But if you've only had it a few weeks then can you exchange it at your retailer? That might be the simplest thing to try.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Changing the output color format to YCbCr422 did allow me to go up to 144, but 200 or 240 is still a no go / shows a black screen.

I have had the monitor for the last 6 months or so, always used the DP cable that came with it, and i have had it running 240 htz up on till the power outage happened, a few weeks ago.

I have yet to try with another DP cable, but i will be testing that as well, when i a hold of one.

Customer Service Agent
Hello, WinkDk.

For issue 1:
May I ask if you can eliminate the ECO Mode from automatically turning on by resetting the monitor?
Please try to press and hold the "MENU" key and select MENU > System Setup > Restore factory mode (Reset) > select "Yes" to return to the initial value of the screen.

For issue 2:
According to the user manual, increasing the frame rate of the ROG Swift PG279QM's DisplayPort input from 144 Hz to 200 or 240 Hz is only possible when the color format is RGB/YUV444 in 8-bit and YUV422 in 8-bit color depth.
Please refer to the link below, check the User Guide for English Edition page 3–14 to confirm whether it matches your present configuration.

Thank you.

Hello, Jiaszzz@ROG

First of all, thanks for your respons.

For issue 1:
Going though the steps "Menu -> System Setup -> All Reset -> Yes" , has not resolved the issue unfortunately.

For issue 2:
I have attached a picture to my initial post, that show my present configuration. As far as I can tell, it is within the limits specified for 200/240 Hz according to the manual. Please correct me if I’m wrong on this one.

Thanks in advance.

Customer Service Agent
Hello, WinkDk.

For issue 1:
I will reply after consulting our relevant team.

For issue 2:
Please adjust the "Desktop color depth" to 8-bits and the "Output color format" to YUV422 as well.

Thank you.

Hello, Jiaszzz@ROG

For issue 1:
Thanks and much appreciated.

For issue 2:
The only option i have under "Desktop color depth" is "Highest (32-bit)".

In regards to "Output color format", i only have these 3 options:
- YCbCr444
- YCbCr422

For good measurement, i also tried to "restore defaults" under more or less all tabs that has the option in Nvidia Control Panel, just to see if there could be a checkmark or specific setting that now blocked any of the necessary settings. This did not change anything.

I also tried swapping out the Display port cable for another one, but it gives the same issues.

In case it has any relevance to the issues i'm facing, i do run version of windows (Windows 10 version 22H2 (OS Build 19045.2364), with all updates applied.

Quick thing to add, re-installing GPU drivers didn't resolve issue 2 either.

Customer Service Agent
Hello, WinkDk.

Could you please share the model of the motherboard you use to connect the screen, the brand and model of the GPU, and the driver version of the GPU so that the pertinent departments can immediately comprehend your situation?

Thank you.

Hello, Jiaszzz@ROG



MSI GeForce RTX 3060 Gaming X
Driver version: 528.02