cancel
Showing results for 
Search instead for 
Did you mean: 

Delta S Wireless Charging Issue

F1Aussie
Level 11
Hi all, I am having an issue where my headphones won't charge past 90%. I have tried multiple charging cables and it is the same issue for all. I have only had them for a couple of weeks and have charged them twice now. Any ideas if the headphones are faulty, if it is an armoury crate display bug or there is some sorcery involved in getting them to fully charge?
Cheers
330 Views
25 REPLIES 25

F1Aussie
Level 11
Yay, happy days, had the new firmware show up, installed it and now my headphones charge to 100%

F1Aussie
Level 11
Okay, so new problem. Now the battery % doesn't drop down from 100%. After 2.5 hours of gaming it is still sitting there.

F1Aussie wrote:
Okay, so new problem. Now the battery % doesn't drop down from 100%. After 2.5 hours of gaming it is still sitting there.


Does it change when you plug them into USB? I've noticed sometimes ROG devices don't update battery status until plugged back in.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
Does it change when you plug them into USB? I've noticed sometimes ROG devices don't update battery status until plugged back in.


Hi, just tried, no it doesn't, thanks anyway

xeromist
Moderator
That's all I've got. 😞 Might take another update.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

xeromist wrote:
That's all I've got. 😞 Might take another update.


Yeah, I think so