Showing results for 
Search instead for 
Did you mean: 

DARK HERO X570 unable to get in to BIOS

Level 7
So I had this board for few months now and one thing that really bugs me with this board, a part from few other issues, is that it will not allow me to get in to BIOS (even with current 3801) when pressing DEL key on the keyboard during POST. I'm using EFI boot and CSM is disabled, but during POST I do not get the ROG logo even though I set it to display Full Screen and Fast Boot is disabled. When I press DEL key during POST the PC appears to hang and never starts/boots. The only way I can get into BIOS is if I do hard reset via reset button during POST and after reset I get the ROG logo and I'm able to use DEL key to get in to BIOS, but isn't that basically triggering an OC fail and that's the reason I'm able to get in to BIOS? This just seams very weird to me and I wonder if there is something wrong with my board or is this what everyone else is experiencing with this board?*I'm not doing any OC with this board on my 5950X CPU and even tried disabling PBO and DOCP/XMP on the RAM (which is on QVL) but there is no difference. The GPU I'm using is a EVGA GTX 1080.

There are other issue with this board that make me want to replace it under RMA like a hang on POST (from cold start or reboot) when I have a Sabrant Rocket (SB-ROCKET-2TB) plugged into second NVMe slot which I currently have a ticket for and some other annoying and weird USB issues. The NVMe hang seams like it may be some kind of compatibility issues as the board is not able to read SMART from this NVMe either, but NVMe appears to be in good condition according to other tools that can read SMART and internal cell health via NVMe drive controller. To get it to POST with this NVMe I have to press the reset button but the above issue with entering BIOS happens regardless if I have this NVMe plugged in or not.

What's inside:
Ryzen 5950X
4x 32GB (BL32G36C16U4B) but I also tried 2 sticks
CPU NVMe slot: Samsung Evo 970 Plus 2TB
Chipset NVMe: Sabrent Rocket 2TB (TLC version) has some possible issues, but PNY CS3030 2TB works fine*
SATA1: Samsung Evo 860 2TB
GPU: EVGA GTX 1080 Hydro Copper
PSU: SeaSonic X-1250
Case: Corsair 5000D

Level 12
You have enabled Fast Boot in the BIOS, you need to turn this off.

How to get in BIOS

Fast Boot setting in BIOS makes no difference if it is enabled or disabled for me and behavior is the same.

Level 12
Hi DCTech,
Have you cleared cmos and make sure all bios settings are default but there was no ROG logo and cannot enter bios via pressing DEL or F2?
If yes, please remove all HDD and SSD and then try again.
Thank you.

I just tried reseting CMOS using the CMOS reset button on the back IO and that helped slightly as the POST does not hang when I keep pressing DEL key during POST, but:

1) When I tried 5-6 times to restart the PC from Win 10 I could never get in to BIOS when pressing and releasing (~2/sec) the DEL key on POST. The ROG logo does not show up and PC just boots directly in to Win.

2) When I try to shutdown Win and wait 5-10sec then start using power button, out of 5-6 times I tried, I was able to get it to BIOS only 1 time while all other times I was booted directly in to Win and again ROG logo did not show up during POST except for that 1 time.

Note that after clear CMOS I only change the following in BIOS from defaults:
- Set CPU fan to PWM
- Enable DOCP on RAM
- Ensure Windows Boot Manager is selected as the first boot choice
- Under Boot Configuration:
-- Fast Boot = Disable
-- Boot Logo Display = Full Screen

Note that Win 10 fast startup is disabled and I even tried reflashiong 3801 BIOS and reseting CMOS again and still no change. So far the only reliable way for me to get in to BIOS is to do hard reset during POST which I thing triggers OC fail and that is why ROG logo shows up and I can get to BIOS. I even tried setting POST Delay Time to 3sec in BIOS Boot Config and repeated the 5 reboots and 5 shutdowns and still similar results.

Why do you want me to remove HDDs? If I cannot get in to BIOS with my 2xNVMes and 1xSATA then I'm definatelly not planning to remove them every time I need to get in to BIOS.

Level 12
Hi DCTech,
I want to figure out it is HDDs related or motherboard itself, so want to check if it can get in to bios without the HDDs.
Did it occur after any settings or components changed?
May I double confirm you have tried bios all default but still cannot get in to bios? or you can get in to bios with bios all default settings about 4-5 times?
Thank you.

I can get to BIOS when I don't have any HDDs to boot from as it will halt on POST but when I add drives or configure default boot device in BIOS it will no longer show the ROG logo on POST and will go directly to OS (on whichever NVMe I select to boot from first) not letting me get back in to BIOS using DEL key during reboots or cold start unless I press the hard reset button during POST. Just got my advanced replacement board, installed it over the weekend, but the same issue persists 😞 Yes, I tried this with all BIOS defaults after clear CMOS too and same result. I did not really notice this until recently as I've been booting only one OS and did not have to get back in to BIOS after initial setup, but I'm trying to setup dual boot with Windows on 1 NVMe and Linux on 2nd and would like to switch the boot between them occasionally and this brought this issue up.

I don't know what else I can do except to just install a custom EFI boot manager on one of the NVMe drives to allow me to select which NVMe I want to boot from if I want to install two OSes (1 on each NVMe) and overwrite the boot selection occasionally between Windows & Linux on this board unless you have other suggestions?

Level 12
Hi DCTech,
If you only install one NVME m.2 ssd, does it show ROG logo on POST and can enter bios utility?
or still occurs with one NVME m.2 ssd(windows or linux) installed?
Thank you.

So I think I narrowed down the issue and came up with a workaround. First this issue has nothing to do with HDDs plugged in as far as I can tell. I actually found an older post where someone else ran in to this exact issue:

The above post was right on the money with this problem which is encountered with DisplayPort (DP) connection only in native UEFI mode (CSM off) and does not appear to happen with HDMI as I tested HDMI with the same monitor and it did display the ROG boot logo each time. My monitor is the Acer Predator 4K 144Hz (DP 1.4 & HDMI 2.0) and to get the higher refresh rates I need to use DP so HDMI is out of the question. I do not know if this is UEFI issue in the board BIOS, GPU firmware or a combination, but to get the video working every time on POST I have to enable CSM even though I'm not using legacy boot. It's interesting that video does work if I press the hard reset on POST with CSM off but it only works once and then reverts to no signal on consecutive boots. CSM (which is not enabled by default in BIOS) does output the video over DP during POST on this higher resolution monitor, maybe because it lowers the resolution? I tested a low spec (1920x1200) Dell workstation monitor with this board in native UEFI (CSM off) and this problem does not occur so it is something related to higher resolution and DP specifically.

I did not run in to this issue with the same GPU+monitor on my previous build (Rampage IV Extreme) Dark Hero replaced as the old board did not have native UEFI and only came with CSM boot.

I finally found the permanent fix thanks to JayzTwoCents recent YT video! Thanks to his video I realized the issue on my GTX 1080 was caused by an outdated UEFI DP FW on the GPU and that's why HDMI worked while DP did not! Simply download and install the Nvidia UEFI FW update following link below and issue is fixed.