Showing results for 
Search instead for 
Did you mean: 

Bluetooth Random Disappearing & Unknown USB Device (Device Descriptor Request Failed)

Level 7
This is crazy man, this is happened to my ASUS ROG GL503GE laptop these past two weeks, and I had to clean install my Windows 10 4 times, using Ubuntu 20.4 didn't help either (my laptop will suddenly freeze). Even sometimes when clean install my Windows 10, it can't detect any WLAN networks.

I noticed that somehow my BT and WLAN drivers are not using the one from the manufacturer, but I think those have been like that for 1 year since I have bought the laptop, because I immediately clean install the laptop after bought it.

The symptoms of this problems always like this:

  • 1 BT is not detected, this USB error showed in the Device Manager
  • 2 Suddenly WLAN is not detected too
  • 3 Laptop freeze, hard disk LED turned off suddenly

After contacting Intel and ASUS (via MyAsus) CSs, I reinstalled the BT and WLAN manufacturer's drivers. It ran smoothly for 3 days. But then, yesterday, after I left my laptop to sleep while in the battery mode, the BT is not detected again.I had to keep doing cold reboot and reset BIOS many times until the BT or WLAN is working again, even so, when I turned on my laptop, only the power button and / or backlit keyboard light got turned on, the LED light wasn't turned on except if I leave alone the laptop for about 20 minutes.I'm worried that the root cause of the problem is the undervolting both CPU and GPU, but even then, my laptop worked fine for 3 days with applied undervolting!

After I followed this guide and the one that mentioned that you need to shutdown your laptop too, I can have both BT and WLAN working fine now (and I do hope so forever), but this is getting outrageous like there is no clear explanations for this, and I'm gonna spread this issues around the internet so anyone that come across this issue will have some clues.

Is there any permanent fix for this issue? I also think is might come from the latest Windows update, because everything worked fine before these past two weeks.

Level 7
After I reinstalled my Windows 10 again, installed BT (v20.50.1.2) and WLAN (v20.50.3.3) drivers from the ASUS's site, and edited the Group Policy for disabling Windows automatic drivers update (since I'm using Windows 10 Pro), this problem doesn't happening again, although my BT connection is very unstable, like my Nintendo Switch Pro Controller through BT always got disconnected after I just connected it or getting disconnected sometimes when sending files from my phone to my laptop with size around 1 - 5 MB (this problem doesn't happened with the Window's driver version 21.30).

Thanks for sharing

So ASUS has released a new BIOS version, ver. 318 and after I installed it, no problem so far even using Windows Update's WLAN and BT drivers.
But the problem now is, my offset voltage settings (using ThrottleStop ver. 9.2) are not being applied, even the offset slider in Intel XTU are greyed out.

I've contacted this to ASUS CS in my country, Indonesia.

Please ASUS, let us can also apply the undervolt settings so our laptop can become cooler! 😉