Previous Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

my pc shuts down and and turn on randomly

hello everyone i have motherbord asus maximus xii hero z490 cpu i9 10900k memory 2x16gb g-skill trident z 3600 cl17 my gpu is asus strix rtx 3080 ti ocand my power supply is antec 1300w. today i turn on my pc and after 10 minutes is shut down and tur...

ROG STRIX X470-F Gaming - BIOS Upgrade Error

I am running a ROG STRIX X470-F Gaming with BIOS version 5406 - Nov 13, 2019The support download page shows the last BIOS version as Version 5851 - Jun 28, 2021Using Asus AI Suite 3 - online check says no new BIOS version available. Downloading and t...

89333

Panel overdrive button missing

Panel overdrive panel button missing from armoury crate app...my laptop is asus rog scar 17 g733qr with 300hz and 3ms display..

90056
souliar7 by Level 8
  • 5871 Views
  • 13 replies
  • 0 kudos

XIII Hero 11900k, display doesn't turn on after AFK (iGPU)

Hello,there's a weird problem with my XIII Hero (bios 1102), 11900k & iGPU (HDMI). The PC has no external GPU.I'm using the latest chipset & iGPU drivers.After turning off the display, and going away for 10 mins+, when I come back the display stays b...

Jaqey by Level 7
  • 383 Views
  • 1 replies
  • 0 kudos

Coil noise Hero XIII...!

I just bought a Hero XIII board with a 11900K cpu amomg other expensive hardware..when i move my mouse pointer aroundthen i hear coil noise from the cpu area on the motherboard...I tryed to disable C states and make the same tweaks to bios. but nothi...

Psycrow by Level 11
  • 528 Views
  • 3 replies
  • 0 kudos

Unable to use WOL in Asus Crosshair VIII Hero (Wifi)

Hello Everyone,I am unable to use the Wake on LAN feature in my Asus Crosshair VIII Hero (WIFI). I turned off the fast boot from both bios and OS. Enable Allow computer to turn off this device, Wake this device, magic packet in both ethernet ports. ...

Armoury Crate Install Error 100 - Always Reproduces!

Hello all,Enjoying my Strix Scar 17" 2021. Very much, except for the MyAsus and Armoury Crate software.This thread is for Armoury Crate, so here goes:1. I *always* get error 100 while installing on my production system. Please see screenshot.2. I do ...

Welcome to ROG Care

For any technical difficulties, you may contact Jiaszzz_ROG, Aureliannn_ROG, Alvez_ROG

Helpful Links:

Labels