Showing results for 
Search instead for 
Did you mean: 

Asus Z690-E Gaming post problem

Level 7

Recently built a new computer for my kid, using the z690-E original bios v0503 updated to v1505, the machine is having issues posting it can take more than 30 seconds going through the postcodes and will have to force it to shut down as it will just hang with a black screen. Even if we manage to get in to win 11 we have no issues, its just after attempting to restart, that the machine repeats the same issues and has trouble posting even with A0 code, sometimes the postcodes hang cycling through them taking longer than 30 seconds before reaching A0 with no post. After a bit more troubleshooting I tried the onboard graphics and the machine posted each and every time no issue, so I moved the GPU to the next PCIE slot, and the same result of no issue posting. When I moved the card back to the first slot the issue happened again. Do I have a motherboard with a faulty PCIE slot?

I was having this exact issue with v503 as well, that is why I updated the bios.

CPU Intel Core i7-12700K


MEMORY G.Skill Trident Z5 RGB Series 32GB (2 x 16GB) 288-Pin SDRAM DDR5 6000 (PC5-48000) CL36-36-36-96 1.35V

POWER SUPPLY EVGA Supernova 850 T2, 80+ Titanium 850W

COOLER Lian Li Galahad AIO 360 RGB UNI Fan SL120 Edition Black


OPERATING SYSTEM Windows 11 Home 64 Bit 1Pack

GRAPHIC CARD 3080 Founders Edition GEFORCE RTX

Level 9
Have you tried forcing lower PCIE Gen? Advanced -> SA -> PCIe. Does it run fine on 3rd gen?

I will give that a go, and report back thank you, as I didn't know about that feature.

DragDay7 wrote:
Have you tried forcing lower PCIE Gen? Advanced -> SA -> PCIe. Does it run fine on 3rd gen?

I changed the PCIE to gen 3 no good, then tried Gen 4, same result black screen. If I ever manage to get the machine to post in the top slot it can blue screen.

Level 9
What about moving M2 drive from M2_1 to another one?

Also have you tried running default bios settings without xmp?

Yes I have run the default Auto instead of XMP. I have a 1TB m.2 drive at the top slot, and a 1 2TB m.2 drive at the bottom slot. My OS is on the top m.2 slot I can try moving it. But shouldn't it work regardless if it's populated? I might just settle for RMA on this.

Level 9
Doesn't hurt to try. Also your specs doesn't mention the second M2 drive. M2_1 goes directly to CPU just as the PCIe 5.0 that you're having issue with. I'm just wonder if your components are in conflict. They shouldn't be. You could try setup bare minimum parts to run OS with gpu or even without M2 drives to see if it gets into bios. Maybe you could inspect that PCIe socket if there's a damage, bent pins?

Level 7

Did this get resolved.? Just put my rig together :-
Intel 12 Core i7 12700KF Alder Lake CPU/Processor
Kingston FURY Renegade 32GB (2x 16GB) 6000MHz RAM KF560C32RSK2-32
Samsung 980 PRO 1TB in CPU M2 port.
EVGA GeForce RTX 3080 FTW3 10gb

Just checked the NVidia firmware suggestion, card was already updated.

Have you tried plugging in your display cable to you onboard graphics via motherboard and installing GPU drivers?

I've ran into an issue with the my Z690-E bios splash screen showing up prior to booting Windows 11. The issue is very simple and related to the bios settings ADVANCED>SYSTEM AGENT CONFIGUARATION>PRIMARY DISPLAY>CPU. I have tried multiple times to change the setting from CPU to PCI-E and even AUTO. Each time the system reverts the setting back to CPU. This only allows me to enter bios whilst changing my DisplayPort from the GPU to the motherboards on board graphics via CPU.

If you can post windows via onboard graphics and install the GPU drivers. You should be able to boot the computer and it will post windows via GPU. However you will need to plug the display cable into the motherboard every time you need to register the splash screen to enter bios. I'm currently seeking information on how to fix the BIOS issue.