cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS SUPPORT NOT HELPING AT THE MOMENT two asus PG258Q Monitors FAULTY

USERMAC
Level 9
I have two asus PG258Q Monitors both have been replaced twice from the shop but still have this problem with BRIGHT Vertical Lines running through top to bottom of the centre of the screen. Also when I switch off the monitor and switch it back on it gives me error no display port so I am forced into restarting pc in order to get the display to turn back on.

Asus support has been completely useless so far, I have tried explaining the problem and all they say is this is the first we have heard of this problem and that they want to replace my screen with refurbished ones !

This is terrible Asus I have spent over £1000 on these screens why would I would to swap for a second maybe third hand screen just to get the same problem!

Has to be a firmware update for the PG258Q ?

I do have an RMA but this is not working out as I have been trying to call and am on hold for about 15 minutes and then the line hangs up every time I try soo frustrating that I have this problem with the screen and let alone Asus Support line not working either.

PLEASE CAN SOMEONE ACTUALLY HELP ME 😞
5,300 Views
2 REPLIES 2

Bill
Level 7
Hello USERMAC
Can you please send me a PM with any of the following details that you do have available?

Product S/N:
Case ID#:
RMA#:

Also please pass me your contact details:
Full name:
Phone#:
Email:

I'll pass your case to related personnel and department for further investigation
Thank you

Eleiyas
Level 10
EX ASUS Employee here.

Does this happen with every monitor?

If so, it might actually be a problem with the graphics card(s) in your computer.