Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix X670E-I M.2 (And USB) problem in Boot

Level 7
Hello to all.

I have an Asus Rog Strix X670E-I (Mini ITX) board since a few weeks ago. It has a problem that I don't know if it's a BIOS issue or if the board is broken...

The problem is that randomly (approx. 50% of the times) does not detect one of the two M.2 modules (specifically the 2), also not the NZXT controller of the AIO that is connected directly to a USB on the board. Moreover, the boot is much slower... Before I had the operating system in this M.2 slot and of course, the PC wouldn't boot... I had to swap the M.2s and the problem persists, so it's not the memory, but the slot.

I have flashed the latest version of the BIOS and left all the factory settings. Also, as it is a problem that appears from time to time when booting the computer, I thought it could be due to something wrongly connected or loose, but I have opened the PC and checked all the connections, including the M.2 and the problem persists...

Is the board broken or this behaviour could be due to something I have to configure in the BIOS?

Best regards.

Level 7
Problem/Mistery solved. 🙂

Same problem how did you solve it?

Customer Service Agent
Hello, TonyML.

I'm glad your problem has been solved.
It is recommended that you refer to the following link for troubleshooting any problems you might have if you run into the M.2 problem next time.

Thank you.