Showing results for 
Search instead for 
Did you mean: 

Z370 F Motherboard Issues

Level 7
Hi there,

My first post here!
Not sure where to post this as it covers a few problems at once..maybe they are related..

Ok, so i have a few problems with my first build. I built it in December last year and it's been great up until recently..

Intel i7 8700k
Asus Z370F Gaming
32gb Corsair Vengeance Pro
2 x Samsung 1tb SSD
1 x Samsung 250gb M.2 nvme
EVGA Supernova G3 750 Power supply
NZXT H500 Case
Windows 64 bit

Like i said, when i built it, it was all good. I slightly overclocked the CPU to 4.6 and the ram to 3200 watching guides on youtube. I pushed the graphics card a little too, watching their videos and using Precision software. This PC is for photography editing on one screen (BENQ SW320) and gaming on another screen (ASUS PG278QR) I didn't mess with any voltages as im a total beginner at this.

All fans spinning in bios all decent temps. ( 1 x cpu fan 2 x exhaust case fans )

The only thing that's never worked is the Flow Control Software from EVGA. The usb socket on the board (AIO PUMP) has never made the windows usb sound when plugging in or out. Trying to open the software gave me a DEVICE NOT FOUND error box. As everything worked and i didnt care to change the colour of my EVGE logo i left it.

I started up my pc about a month ago and randomly got a CPU FAN ERROR F1 to SETUP SCREEN. In the BIOS the CPU fan picture was not spinning and i had to set the CPU FAN to IGNORE to make it boot. Fans work fine and cpu is cool on idle (about 23c) Also the lights go out on the EVGA logo the next day..

I spoke to EVGA who said they wanted to see it, they sent me a new one then claimed the last one was actually fully working...Soooo why send me a new one? They advised i spoke to ASUS about the sockets on the board.
The new clc280 works fine (follows q control curves) but doesn't show in the bios and the logo is lit up again. Flow Control still doesn't work.

I spoke to ASUS and they said to clear the CMOS, but still the same
After that, Asus said to send the board back for inspection from where i bought it. I had to take pictures of the cpu socket before they (eBuyer) accepted the rma. Unfortunately we found a couple of bent pins on the socket and they refused the return. I watched a few videos and set about moving the pins back into place. It went really well and every pin is perfectly aligned now.

I rebuilt the pc and really thought that was it but it's all the same.

In the bios i just noticed the CPU is at 1.040..isn't this a little high? I've never changed any of the voltages and with a little research that seems too high..?

Lots of info sorry, maybe someone can help.

Already looking at a new board and prepared to take it on the chin that i must have damaged the cpu socket.