Showing results for 
Search instead for 
Did you mean: 

Z170 Pro gaming - works with newer RAM, doesn't boot with original set.

Level 7
Hello all,
I hope to get some advice (though I've tried everything logical as it seems already).
I have a system assembled back in 2015 consisting of z170 pro gaming 6700k and a pair of G.Skill TridentZ 3200 CL16 sticks.
Before TridentZ sticks I used to run a pair of Ripjaws V 2800 15-16-16-35 sticks. I recently wanted to move the TridentZ sticks to a newer system and put in the original Ripjaws V instead. However, the system outright refuses to boot with RIpjaws even in bios (get red light on mobo) no matter in which slot or which stick I use (tried separately and both in various combinations). The moment I put TridentZ sticks in - it works again.

Now, the Ripjaws V sticks work fine as I can run them without an issue in the newer system (it works without a hitch with both sets), while the Z170 pro gaming system refuses to run with its original sticks despite that I used to run it with them for a long time back in the day before putting TridentZ in. Clearing CMOS doesn't help.

I'm out of ideas at this moment. Can it be that somehow the latest (or some earlier bios) have screwed up the compatibility with this particular set? Otherwise I can't see any other reason for newer system to work perfectly fine with both sets, but the z170 to refuse to start with its original sticks, while having no issues with TridentZ.