cancel
Showing results for 
Search instead for 
Did you mean: 

USB 3.0 ports not working on new build

CallumK91
Level 7
Just built a new PC, everything is running absolutely fine except for the USB 3.0 ports.

I have 2 in the front of the case (plugged into motherboard) and another 4 built into the motherboard. All USB 2.0 ports are working fine. I have had a few times where the light on the USB 3.0 flash drive has come on when plugged into one of the USB 3.0 ports, but it does not flash as it should, and it does not show up at all in Windows. No noise to notify me that it has been connected or anything, and the majority of the time there is no light on the flash drive.

I am assuming this is a driver issue however I am having no luck obtaining any solutions/drivers.

My setup is:

Motherboard: Asus Maximus VI Hero
CPU: Intel i5-4670k
OS: Windows 8.1

Any other info required just request.

UPDATE: I have installed latest BIOS and still no luck.

UPDATE 2: Problem solved. Setting in BIOS USB configuration, set to Smart-Auto causing it to only send enough power to allow USB 2.0 devices to run in USB 3.0 ports. Disable setting = USB 3.0 devices work.
10,550 Views
3 REPLIES 3

abvolt
Level 11
Did you install the controller driver for usb 3.0 if not you need to do that..
Current: MSI Xpower Gaming Titanium | 7700K | G Skill Ripjaws V 3000 16Gb | 960 EVO 500Gb | Intel 730 480Gb | Seasonic 1000 Platinum |
NZXT X62 | Acer XB270HU | EVGA 1080 ti FTW3

Secondary: R4BE | 4930K | G.SKILL 2400 16GB | Corsair AX 1500i
Intel 730 240GB + 480GB | EVGA GTX780 ti sli kpe | Custom H20

Do you mean "Intel USB 3.0 eXtensible Host Controller - 0100 (Microsoft)"?

If so then that was installed in the installation of the OS.

CallumK91
Level 7
Problem solved. Turns out it was a setting in BIOS in USB configuration.