Showing results for 
Search instead for 
Did you mean: 

The ROG RAMDisk Software

Level 15

Those of you buying any of the Maximus VI motherboards or new RAIDR PCI-Express SSD, you will also have received the new ROG RAMDisk software bundled in your pack. I hope you didn’t chuck that box and disc out just yet!

Since ROG is always in the pursuit of performance and its users often pack their systems with memory, the RAMDisk software makes perfect sense. A RAMDisk offers a magnitude of performance over traditional storage, as shown below.

You’ve overclocked to 4+GHz so why not make use of all that extra RAM to boost your storage performance as well? Game or application loading, virtual machines (although Intel K series don’t support VT sorry) or other workstation-class software that demands ROG-level extreme compute power will all show a notable benefit.

Unlike many other RAMDisk software, the benefit of the ROG RAMDisk software is that it has no arbitrary limit; you can make dozens of small drives or just one huge one, for example, and it has certain functions to better preserve the life of your SSD. With NAND write life-cycles becoming ever smaller on each generation, it is key to preserving the long-term life of your SSD.

To learn more about the ROG RAMDisk, check out our innovation page which has more details.

I have the RAIDR Express card running Windows 8.1 in UEFI mode. I'm unable to install the RAMDisk software. At 15% I get the error "FoundDMI Fail" I press OK then get "GetSMBiosInfo Fail" press OK again and get "Fail to initial AsInsHelp DLL" after which pressing OK closes installation.

I've tried the version on the CD, as well as both versions available on the download page (V2.01.03 and V2.00.03.)

Per a suggestion I read in another thread I tried installing the Marvell drivers from the CD but that did not fix the issue.

Does anyone have any other suggestions on how I can get it working?


i download SW_ROG_RAMDisk_W10_64_VER20300_20180130R, for my Asus Rog Strix Z270-E Gaming, but under install i got error, reboot the pc and when i start the Rog Ramdisk do not work.

Is there a solution or maybe a Rog Ramdisk for my motherboar ?

I hope for fast answers.

Kind Regards

Level 7
RAMDISK lost after reboot on windows 7

Hi, I have created 1gb of ramdisk with label R: for example, on windows 7, it work well, but after reboot I have lost the drive letter.

Opening ROG RAMDISK, I can see letter R: but seams that RAMDISK cannot mount the drive...