Showing results for 
Search instead for 
Did you mean: 


Level 7
Hi all,

I have a STRIX Z690-A GAMING WIFI D4, with an intel 12900k cpu.

The memory kit is a DDR4 128GB (4*32) kit from G.SKILL (F4-4000C18Q-128GTRZ).

I installed the kit and with "load optimised defaults" from the motherboard, it works, although at 2133 as memory frequency.

I tried to load "XMP I" from the motherboard, but it fails to boot. The XMP of the kit is DDR4-4000-CL18-22-22-42@1.40V.

Then I tried to load optimised defaults again, and keep everything at "auto" and just set the frequency. Setting RAM frequency at 3200 (and everything else at auto) works. But looking at the rest, it has set CL19 and DRAM voltage at 1.32V.

What I should do to use this kit? What should I set in the BIOS?

Usually buying a motherboard and setting the memory at XMP, with everything else at auto, worked for me in the past.



Level 7
It's a known issue the BIOS/XMP is absolutely borkt. Same issues on that motherboard with two differernt sets of Corsair Vengeance Pro 3600MHz 2x8GB

What BIOS build are you on? I've tried all, currently on 1304 and XMP1 and XMP 2 don't work, manual overclocking doesn't work properly, I can get a mild "overclock" to 2900MHz stable. Won't POST and just boot loops until an error makes me go back to BIOS.


I am also on BIOS 1304. What I did was the following:

1) I loaded "optimised defaults" in the BIOS.
2) Then I selected "XMP II" in the BIOS. This set the timmings for the RAM, the speed and the voltage.
3) I lowered the DRAM frequency from 4000 to 3800 (with 4000 does not boot).
4) I lowered the DRAM voltage to 1.35 (from 1.40).

And it worked. Ok, my RAM was for 4000 MHz, but running at 3800 is also acceptable. (Especially since I have a 4*32 GB kit, of Hynix MJR chips, which are not considered that good).

Level 13
If I am not wrong Z690 and Intel 12 Gen only support DDR 4 up to 3200 speed. In order to work above that XMP mode require to kick in. Asus Z690 very pricky in their RAM timing, latency etc. Try XMP II see if help. By the way, Intel certified XMP but not warranty for that. To Intel, XMP mode considered OC.

I was quite culture shock about it.

I have 2x16GB 4000MHz CL14 RAM kits.
So far, only 0707 BIOS version lets me XMP with 12900KS.
With another BIOS version, I only succeeded with 3800MHz, by proceeding the same way as OP (enabling XMP, decreasing to 3800MHz, decreasing voltage).
With the last BIOS version from two days ago, I couldn't even boot with 3600MHz.
Ok I am very far from being knowledgeable when it comes to computer hardware, but I would have imagined those RAM kits were manufactured and sold for a reason. It really is not transparent what piece of hardware is compatible with what piece of hardware.
So I'm just using the 0707 BIOS version which was released in October.
I'm happy my RAM is fully utilized using XMP2.
Now I'm concerned with taking maximum benefits from my 12900KS, right now with stock settings the temperature is about 55-63°C, I think it's quite low (I have a good cooler, Corsair iCue H170i LCD Elite - 420 mm).

I am still using the DDR4 kit at 3800. My bios is 1304.

In fact, my system is very stable at this setting, it is running Linux and the uptime is 3 months!
(The pc has been open continuously for 3 months)

Level 7
It's well known the BIOS is an absolute dumpster fire. Im about to try the latest BIOS 1706 but I have 0 confidence it will do anything.

Tried differernt ram, different channels. Best I can get is my 2x8 3600MHz set to 3000MHz on 1504.