Showing results for 
Search instead for 
Did you mean: 

STRIX Z370-G wont boot with ram speed above 2133mhz

Level 7
Long story short... My system will not boot with any memory speed over 2133Mhz.

Memory: 2x G.SKILL TridentZ F4-2800C14D-32GTZ
CPU: i7-8700
Motherboard: STRIX Z370-G Gaming (Wifi-AC)

I have tried setting XMP and manually adjusting the settings. The only setting that causes the system to not boot is ram speeds above 2133Mhz. I can set XMP and lower the speed to 2133Mhz and everything works at stock voltages. To get the system to boot with higher speeds I have tried adjusting voltages based on other posts with similar issues but nothing seems to be working.

DRAM: 1.4v
VCCIO voltage: 1.2v
System Agent voltage: 1.2v

Any help would be appreciated!

Level 12
Have you tried using the XMP setting with just one stick of memory in the 2nd slot 'A2" away from the CPU?

Try doing this with one stick at a time to see if either one can be booted at XMP. Then try them both at XMP, one at a time, in slot 'B2".

You may be able to isolate the problem to a particular slot or memory stick this way.

Thanks, I will give that a try this evening.

So i just went through DIMM by DIMM and tested them all. They all booted with no issue with XMP @ 2800mhz.... i put them all together and they STILL all worked! The only thing I can think is that re-seating them resolved something or, pairing them up by serial number matched the pairs correctly.

Level 12
Hey that's good then. Maybe something to do with memory training by the board or who knows glad it's working now.