Showing results for 
Search instead for 
Did you mean: 

Rampage IV Gene stuck at BIOS screen, del key not working..

Level 7

I have an old Corsair ssd primary drive with Windows 7 and its health is not the best, but was running ok, it was reported at "84% healthy" from a utility i use (Hard Disk Sentinel). I performed a checkdisk from WIndows, scheduled at next reboot. I saw the checkdisk commencing and when i returned the screen was stuck at BIOS with no keys responding. It is 8 years that i use this motherboard and this primary ssd hard disk and no problems at all till now, either in BIOS or in Windows.

The setup is:

Asus Rampage IV Gene
i7 3820
Gigabyte GTX 670
Corsair Force GT 120gb
Caviar Black 1TB
Kingston Hyper X 16gb
Corsair Professional modular 750w
Lian Li 351

The pc boots, shows the BIOS screen followed by a beep, then goes black momentarily and returns to the BIOS screen, unresponsive, leds stuck to 30. Del, F2, F8, F12 not working. I never had to use the ClearCmos button and i made the mistake to use it while the computer was on, but i don't think i did any damage.
I used the clearcmos button properly several times and tried removing the battery, no change. Then i went through the manual for the first time and noticed the Q led option. Indeed i found out that the "BOOT_DEVICE_LED" remained lit, so i guess the checkdisk tried to fix some sectors and the ssd boot drive became unbootable?
But if that is the case, why would entering BIOS be affected?
The other leds do not stay lit, so i guess there are no problems with cpu, ram, vga.

Any suggestions? Thanks.


After disconnecting the ssd, it went pass the BIOS screen to the settings. Everything seemed ok. Reconnecting the ssd, it now gets stuck to the BIOS screen, with led stuck at 90.
I mostly want to find out if it is a matter of the ssd, or of the motherboard. I recently found out of the existence of the SATA/IDE to usb adapter, i haven't been following technology lately. I hope i do not lose the ssd completely.

Level 7
It turns out i forgot to check for BIOS updates during the last years and my BIOS version was from 2012. After a long search for the BIOS converter that i needed, i managed to update the BIOS to the last version. Looks smoother but no change in the problem. When the boot ssd is disconnected i can normally enter the BIOS and choose boot priorities. I chose the DVD drive as first priority and reconnected the ssd. The screen again gets stuck on the BIOS screen with no key working and the debug code is 06 (not 90, i was reading it backwards) and the boot Q led lit.
So even with the latest BIOS version, i am not able to insert a WIndows 7 repair dvd, because the BIOS freezes when the ssd is connected (to various ports). It puzzles me, i was under the impression that BIOS is not related to the OS, or to the boot drive, and that it loaded separately. I don't know if the ssd is dead or just the WIndows installation is corrupted, i hope i will not lose my data (waiting for a SATA to usb cable), but i don't understand either if the motherboard has some problem or not. With the ssd disconnected, it is as if nothing is wrong when i enter the BIOS. I could not change the year in the date and i thought maybe that was a sign of a fault, but it turns out it can easily be set in EZ mode, just the keys were not working in the Advanced mode. But with the ssd connected, everything freezes.