cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus VI Hero first power up

Balkhan
Level 7
Curious as to what I should see when I first power up a Maximus VI Hero. This is my first PC build.
On power-up I get a short beep and a Q code A2, with the Boot_Device_LED on the mb on. The monitor shows "Delete key or F2 to enter BIOS" message but I never get the BIOS....just disappears after a while to a blue screen with the ROG logo.

Is this a correct POST test result or is there something wrong - should I be able to enter the BIOS?

thanks

EDIT: I have no vid card (using the onboard graphics via HDMI), two 4GB RAM sticks in the red slots, I have an optical drive, HDD, and SSD hooked up to Intel SATA ports on the MB and to power. H100i CPU cooler - it's not too tight - I just finger tightened it then turned a little more with a screwdriver.
2,161 Views
3 REPLIES 3

Arne_Saknussemm
Level 40
The cooler should only be finger tight...no need for screwdriver ever this can displace CPU and cause problems. but assuming you havent tightened more than the merest tiniest bit?...

have you tried clearing CMOS...different SATA cable...sure it's in Intel sata III ports...single stick of RAM....checking all power connections are seated well etc.

Are you pressing delete and nothing happens? keyboard usb or PS2? connected to USB 2.0 port...

Powered up again, and the PSU shut down then back on - acted like there was a short. So I removed the CPU and there is a bent pin. It's so small and fragile looking I don't think I can fix it.

Maybe I did tighten the H100i too much? - I put the CPU in just like all the vids I watched said too.....

EDIT: yes I cleared CMOS, disconnected all SATA cables, removed 2nd stick of RAM, before I found the bent pin.

Arne_Saknussemm
Level 40
Hmmm...sorry to hear that! They are delicate but not that delicate. I have solved this myself once with a pin and magnifying glass and a steady hand. Or maybe take the board to a jewelers?....