cancel
Showing results for 
Search instead for 
Did you mean: 

Installed new SSD, not booting as fast as I would expect. Feedback

MenaceRx
Level 7
I recently installed a Samsung 850 EVO SSD into my rig. But it doesnt load up as fast as I was expecting it too. I have a 250 GB version in my latop, and the 500GB in my desktop. The 500 has replaced my main system drive.

I am wondering what if any settings I might need to adjust in the bios to turn up the performance.

All sata ports are set to AHCI, and ESP is off, no idea what ESP is, but the manual doesn't give an elaborate explanation of it

My setup....

Win 7 Pro 64
FX 8350 w/ Corsair H60 Liquid Cooler
Asus Crosshair V Formula Z Board
32 GB G. Skill Ripjaw @1600
Samsung 850 EVO 500GB SSD (Main Drive)
Seagate 1TB SSHD (Game Drive)
WD Black (x2) file storage
Powercolor 7870 GHz Edition 2GB
Thermaltake 750W Modular
6,304 Views
9 REPLIES 9

MeanMachine
Level 13
Hi MenaceRx

Have you also enabled AHCI mode in Bios? Use Samsung Magician to check if AHCI is enabled and your OS is optimized. Also run a benchmark and post the results for Read/Write times.
Also check Rapid Mode is enabled.


If you installed the OS prior to enabling AHCI, you will have to make a change in your Registry to allow the AHCI drivers to load.
I can help you with that if needed.

My 840 benchmark

46652

Your 850 should be quicker as mine needs a firmware update.
We owe our existence to the scum of the earth, Cyanobacteria

My System Specs:

MB:ASUS ROG Crosshair VII Hero/WiFi GPU:EVGA GTX 1080 sc PSU:Corsair AX-1200i
CPU:
AMD R7 2700X Cooler: Corsair Hydro H115i Case: Corsair Carbide 780t

Memory:G.Skill TridentZ F4-3200C14D-16GTZR SSD:Samsung 500GB 960 EVO M.2


[/HR]

MenaceRx
Level 7
Thanks here you go. This is my first desktop use of a SSD, my laptops runs smooth and snappy, I just feel like the drive is under performing and want to get the most out of my upgrade.


46658

46659

Here's my benchmarks for my 850 EVO. Basic system specs: 5820K, 16 GB DDR4 2400, Win 8.1, etc. I did not use any of Magicians optimizations.

46718

MenaceRx
Level 7
Talked with the Samsung rep, did some optimizations, only one category took a hit. Everything else improved. Now I am running 5 drives in my sata controller which I was told can have an effect on performance for the drive. Probably why I have the disparity in the laptop 250GB EVO i have installed and this one. Less things running through the Sata controller. might have to look at the drivers and see if I need to update those.

MenaceRx wrote:
Talked with the Samsung rep, did some optimizations, only one category took a hit. Everything else improved. Now I am running 5 drives in my sata controller which I was told can have an effect on performance for the drive. Probably why I have the disparity in the laptop 250GB EVO i have installed and this one. Less things running through the Sata controller. might have to look at the drivers and see if I need to update those.


It looks like you've enabled Samsung's Rapid mode to give you higher throughput in sequential read and write. That measurement seems more like it's measuring RAM speed since data is cached in RAM. I'm not sure why your random read/write speeds are lower than rated.

Here's my 850 Pro without Rapid mode enabled.

46723

randyn
Level 7
MenaceRx,

What optimizations did you do? Curious to see if it would help improve my performance also.

MenaceRx
Level 7
Yeah I turned on rapid mode, adjust some power plan settings and made sure all the optimizations are on. As for the others not sure why the Randoms are lower then they should be, I am assuming it's the multiple devices on the sata controller. I am on BIOS 1901, what version are you on? Were there any changes in the BIOS updates that improve SSD performance for the Crosshair V board?

Limabean
Level 7
I've got a different motherboard, so I don't know about BIOS changes for your board. I noticed that MeanMachine's test result with Rapid mode enabled shows very fast random read, but slower random write. I haven't played with Rapid mode so I don't know whether it impacts random read/write speeds. My SSD is so much faster than my mechanical secondary drive that I don't feel the need to enable Rapid mode at the moment.

Here's a thread on another forum that I found helpful in navigating the Samsung Magician software (especially the last post):
http://forums.anandtech.com/showthread.php?t=2382534

MenaceRx
Level 7
Thanks, I will look it over, I really think my problem is the 6 sata ports and probably my configuration I have them plugged in to. If I move some stuff around and prioritize it, or swap over to a Intel i7 and board with M2 and sata express I would expect a performance gain, but I am not ready to throw out that money yet, the i7 isnt my problem in choosing for the next upgrade, the Z97 boards seem to be very finicky in every brand from all my research, dont know why the Haswell refresh caused so many problems with all board makers but i have read enough bad reviews now to make it very hard to pick a new board. Having the formula variant right now I really want that same board in Intel by ASUS.