Showing results for 
Search instead for 
Did you mean: 

Help needed! Monster PC wont post :C [SOLVED!]

Level 7
So I built an absolutely epic PC only to find that it doesn't post :C

This is what happens when I press the power button: the whole pc lights up, all chassis fans spin including fans on the gpus but after 3 seconds the whole thing shuts off. I don't see any bios text on-screen. No beeps....nothing on-screen.

Here are my specs:
5960x water cooled with single loop
128GB 2800 DDR4 ram
X3 980 ti SLI
Rampage V extreme 3.1 usb version
Corsair 1500i power supply
X2 WD Red 6TB drives
X2 1TB Samsung 850 pro SSD in raid 0
1.2TB Intel 750 PCIe SSD

EDIT: at first I thought it was the 128 GB ram so I updated the bios using a usb stick on the ROG port but still no post.

Level 12
Disconnect all USB devices as well.

I would focus on the PSU, do you have another unit to test in this new build?
Intel i9 10850K@ 5.3GHz
ASUS ROG Strix Z490-E
Corsair H115i Pro XT
G.Skill TridentZ@ 3600MHz CL14 2x16GB
EVGA RTX 3090 Ti FWT3 Ultra
OS: WD Black SN850 1TB NVMe M.2
Storage: WD Blue SN550 2TB NVMe M.2
EVGA SuperNova 1200 P2
ASUS ROG Strix Helios GX601

NemesisChild wrote:
Disconnect all USB devices as well.

I would focus on the PSU, do you have another unit to test in this new build?

ill be getting two things tomorrow: 1) a simple 4 GB DDR4 stick and 2) a 1200W power supply that doesn't have 15 amp power plug. will test and see how we go then.

If the bios update was successful then it shouldn't be the ram but give us an update with the 4GB stick and new psu.

Good luck I got my fingers crossed.

Level 7
OMG OMG OMG!!! I got the PC to post!!!!!!!!!!!!!!!!!!

you would never have guessed what the problem was!

part of the pc build I decided to replace the stock momentary anti-vandal power switch with a momentary ''LED'' anti-vandal switch. I unplugged the power switch from the front I/O pins on the motherboard and used the power on button on the motherboard itself and BAM! instant post.

it looked like the LED anti-vandal switch was somehow triggering a shutdown

thanks for all the help guys! but looks like in the end i just stumbled upon the solution! 😄

Level 7
Hey man, I have a solution here that will make you feel dumb if you did it. I know because I have and it is so easy to do. Check you I/O plate in the back. Sometime that have little spring bits bent inwards that are meant to rest on top or against the motherboard connectors. I have forgotten about these before and they end up sticking inside of one of the connectors line a USB for example. If this happens, it shorts the connection and will in fact cause wired phenomena when trying to boot a new build for the first time.

I've got a machine here that a few years old that would destroy your X99 build. On 3dmark, it is rated in top 2% of all published scores. I was able to play Crisis 2 on highest setting at 200fps or better with Crisis 1(highest setting) and Diablo 3(highest setting) in windowed mode on my second screen without any lag, flutter.

Build Data:
EVGA Classified SR-2 Mobo
48Gig memory in Triple Dual channel configuration
2x Xeon 3.0ghz, Quad-Core 16Mb Cache CPU's
3x GeForce 760 sli


Haha the vandal switch must have vandalized your motherboard, good job getting it going ! 😄

Level 10
sounds to me like he might have switched power and reset switch. did that once and the insulation melted off 😛

Watercooling FTW :cool:

"essentially one of the most hardcore overclocking motherboards ever made."