cancel
Showing results for 
Search instead for 
Did you mean: 

Extremely fps drop on ROG G20AJ

Zhu_Ye
Level 7
Hello every
Recently my new brought computer "ASUS ROG G20AJ" sometimes drops to extremely low fps (lower than 10 fps) when play games that often crash the computer.This happen in almost every game,so it is not a problem of the games its self.
It happens about once a day and I am sure is not due to the Graphics setting(I have try to set the Graphics setting to lowest level but the problem still remain).I tried both the Graphics Card drive 347.71 and 353.06,they have the same problem.And this problem usually happen soon after start the computer and entering the game,so it is not due to the temperature issue.

Do anyone know how to solve the problem?Or do someone have encountered the same problem?
383 Views
5 REPLIES 5

Son_of_Altair
Level 9
Hi Zhu Ye

Have you checked that it is not running on intergrated graphics instead of your gpu? Also try using nvidia geforce experience as it should optimise your game settings to give you a minimum 40fps
Intel 4930k i7 OC 4.6GHz Offset Mode ~ Asus Rampage IV Black Edition ~ 2x 8GB Corsair Dominator Platinum 2400MHz 10-12-12-31 ~ Asus ROG Matrix Platinum 780ti ~ C: Samsung 840 Evo 250GB SSD ~ 😧 Samsung 840 Evo 750GB SSD ~ Corsair ATX 1200i ~ Corsair 900D ~ Corsair H110 ~ 3x Corsair SP120 Red LED fans ~ 6x Corsair SP140 Red LED fans

Zhu_Ye
Level 7
Yes,I check it is.And I have used the nvidia geforce experience.The fps drop does not always happen.Normally my pc can running games smoothly.But the problem I mention above happens from time to time(about once a day).The fps drop is so crazy and it often let to the computer crash.

Son_of_Altair
Level 9
It sounds like it may be something software related. Have you checked for any automated processes running in the background such as security scans/updates?. I would try running a benchmarking tool like ROG realbench and see if the same error occurs there
Intel 4930k i7 OC 4.6GHz Offset Mode ~ Asus Rampage IV Black Edition ~ 2x 8GB Corsair Dominator Platinum 2400MHz 10-12-12-31 ~ Asus ROG Matrix Platinum 780ti ~ C: Samsung 840 Evo 250GB SSD ~ 😧 Samsung 840 Evo 750GB SSD ~ Corsair ATX 1200i ~ Corsair 900D ~ Corsair H110 ~ 3x Corsair SP120 Red LED fans ~ 6x Corsair SP140 Red LED fans

Son_of_Altair
Level 9
Also next time it begins to happen make a note of the system time and check windows event viewer to see if any errors are appeaeing there
Intel 4930k i7 OC 4.6GHz Offset Mode ~ Asus Rampage IV Black Edition ~ 2x 8GB Corsair Dominator Platinum 2400MHz 10-12-12-31 ~ Asus ROG Matrix Platinum 780ti ~ C: Samsung 840 Evo 250GB SSD ~ 😧 Samsung 840 Evo 750GB SSD ~ Corsair ATX 1200i ~ Corsair 900D ~ Corsair H110 ~ 3x Corsair SP120 Red LED fans ~ 6x Corsair SP140 Red LED fans

Thanks.I will try it.