cancel
Showing results for 
Search instead for 
Did you mean: 

Digi+ Power Control Turns Off at 4.6Ghz or Higher?

Steve_N__Mavron
Level 8
What's the deal with Digi+ Power Control from AI Suite 3 for my ASUS Z170 motherboard?

I'm manually overclocking my 6700K but up to 4.5Ghz it is fine and stays on like the screen capture below. If I overclock any higher to 4.6Ghz or 4.7Ghz the Digi+ is turned off. I don't understand what causes that and if I should be concerned.



[sorry for the duplicate attachment]
877 Views
8 REPLIES 8

Steve_N__Mavron
Level 8
[Update] - I got some info on another forum about this:

"It changes because the power requirements for 4.6Ghz and beyond is higher than the optimized settings allow for. The choices for CPU power phase control are; Auto, Standard, Optimized, Extreme. If your setting is Auto then it will choose which setting range is appropriate for your overclock. If you set it manually to optimized, you may run into stability issues. I honestly wouldn't worry about it. Just monitor temperatures regularly to ensure nothing is getting too hot. The CPU power phase setting is a sub menu under the Digi+ Vrm menu in the A I Tweaker tab."


So cool I'm now comfortable at 4.6 Ghz based on learning about this, so no longer worrying about it. Fear of the unknown is gone!

cekim
Level 11
Good to know there is wonk waiting in their assumptions at that point. Thank you.

cekim
Level 11
So, interestingly, I am seeing that @4.7GHz, speed-step seems to be disabled even if explicitly enabled in the BIOS.

I even went and enabled EPU for giggles, I've never had that on before....

It seems, at least in windows, that something is stopping it from throttling the clock down with no load.

cekim wrote:
It seems, at least in windows, that something is stopping it from throttling the clock down with no load.


Make sure your Windows power plan is set to Balanced for it to automatically throttle between full overclock and down to 800Mhz as needed, assuming you are set to core voltage adaptive mode in BIOS with adaptive voltage set to same as you have in manual mode.

Steve N. Mavronis wrote:
Make sure your Windows power plan is set to Balanced for it to automatically throttle between full overclock and down to 800Mhz as needed, assuming you are set to core voltage adaptive mode in BIOS with adaptive voltage set to same as you have in manual mode.


I hadn't had to do that previously, but I see in linux it is throttling as before at 4.7, so you must be correct that it is the OS. Maybe I missed it this time around, I reinstall windows a lot on that machine and use it little to do other than test.

Running Windows 10? If so, the CPU failing to step down at idle after a while seems to be a bug. If you open the Windows Task Manager when nothing else is running, go to the "Details" tab and check to see if "System and Compressed Memory" is eating up around 15% or more CPU time continuously. That will stop SpeedStep from kicking in. It appears to be a Windows bug -- it's what's causing reports of portables consuming battery power too fast. On a desktop, it's annoying and tends to run the CPU a little warmer since it doesn't ever back down the speed.

I've seen my system do it particularly after waking from sleep. A restart will stop it. It took me a little bit to get stable sleep/wake/restart/power-off behavior anyway (Apparently typical of Skylake) so I never noticed it while I had sleep disabled. Once I enabled sleep (and only manually, no sleep timer) I started noticing that SpeedStep wasn't always reducing CPU speed after waking. And a little research shows this is a complaint on a lot of Skylake systems, not just custom overclocked rigs. Haven't found a way around it yet, so I shut the PC down when I leave for work and at night. And here's hoping the next major Windows 10 update ("Anniversary/Redstone") will fix it.
Motherboard: Maximus VIII Hero
Processor: I7 6700K - 4.9GHz OC
CPU Cooler: Corsair H80i v2
Memory: G.Skill DDR4-3000 16GB
Graphics: EVGA GTX 1080 FTW2 1721/1860MHz
Storage #1: 1TB Western Digital Black
Storage #2: 2TB Western Digital Black
Case: Antec Nine Hundred
Power Supply: Antec Edge 650 80+ Gold
OS: Windows 10 Pro

Steve N. Mavronis wrote:
Make sure your Windows power plan is set to Balanced for it to automatically throttle between full overclock and down to 800Mhz as needed, assuming you are set to core voltage adaptive mode in BIOS with adaptive voltage set to same as you have in manual mode.


Just so you're aware, there's a better option than this. Choose the high performance plan, but then modify it :

"Change Plan Settings"
"Change Advanced Power Settings"
"Processor Power Management"
"Minimum Processor State"

The setting defaults to 100%. In the balanced plan, it defaults to 5%. Change this value to 5% for the high performance plan as well. I don't know what else the high performance plan does, but it's enough to make a significant performance increase in several benchmarks over the balanced plan, and you still get all the advantages of speedstep/adaptive voltage.

Qwinn wrote:
Just so you're aware, there's a better option than this. Choose the high performance plan, but then modify it :

"Change Plan Settings"
"Change Advanced Power Settings"
"Processor Power Management"
"Minimum Processor State"

The setting defaults to 100%. In the balanced plan, it defaults to 5%. Change this value to 5% for the high performance plan as well. I don't know what else the high performance plan does, but it's enough to make a significant performance increase in several benchmarks over the balanced plan, and you still get all the advantages of speedstep/adaptive voltage.


Nice thanks! I guess one of the other things balanced plan does is turn off hard drives when not in use and maybe network. I'll try this though.