Showing results for 
Search instead for 
Did you mean: 

AVX Offset Question

Level 8
Hello, resident forum-goers. I've been experimenting with OCing my system and ran into peculiar behavior when applying an AVX offset. I was hoping someone could possibly shed some light on this behavior. For clarification, I will begin by listing system components I believe may be relevant to my question.

CPU: i7 8700k
Motherboard: Asus RoG Strix z390-I Gaming
Bios Revision: 2417 (latest available, I believe)
Memory: G.Skill Ripjaws V 2666mhz

Getting to my question. I established a manual mode OC at 4.8ghz, ~1.2 vcore with XMP II enabled. LLC was set to level 6 (1-7, 7 being highest). MCE was set to auto. Speedshift, Speedstep and C-states were set to disabled. AVX offset was left on auto. VCCIO and VCCSA were set at 1.05v and 1.1v, respectively. For the most part, all other settings were left on auto. I attempted various stress tests, using different software (Realbench and OCCT, specifically) and found the system to be stable and performing properly. I decided to apply an AVX offset of -2. This was the only change I made to the system. Upon booting into Windows HWinfo64 was showing the flag RING: VR Voltage max, ICCmax, PL4 set to yes. Upon both booting and entering stress tests, regardless of whether they used AVX or not, both the core and cache frequencies were throttling. Based on the wording of this flag in HWinfo I took it to mean some type of power or current threshold.

Based on my reading into this particular flag in HWinfo, I found information indicating raising various power and current limits to their max value was recommended to "solve" the problem. So, I revisited the UEFI and tweaked all of those values to their maximum (further reading and experimentation led me to believe this is largely pointless with MCE on auto or enabled... but that is a slight tangent). Upon rebooting the flag remained set to yes and throttling continued.

From here I decided to look at other settings to correct the observed behavior. I started by applying steady increments to core voltage for the overclock. I opted to try this approach because the AVX description explicitly stated applying an AVX offset may require higher core/cache voltage. I would slightly raise the value, boot into Windows and see if the RING flag was set to yes and the throttling behavior was occurring. I went all the way up to 1.3v and no changes to core/cache voltage appeared to correct the behavior. Since I can establish a stable overclock at 5.0ghz with 1.33v it felt odd for this behavior to continue at 4.8ghz and 1.3v. I decided to adjust other settings.

This is where I hit the solution. I noticed if I manually defined both the min and max cache ratio to 44, which was the max value I saw with bios settings at default, the problem disappeared. So problem solved. Well, not quite.

I played a bit more with manual OC to see how far I could push the chip while keeping temperatures within acceptable levels. As I said, 5ghz would run stable but the chip is not delidded and the temperatures were above my comfort zone. 4.9ghz felt like a sweet spot. Interestingly enough, even with the min and max cache ratios set to auto and AVX offset at -2 neither the 4.9 or 5ghz OC's had the earlier mentioned throttling issue.

Later, I opted to go with a 4.8ghz overclock using adaptive mode. I had to play with vcore and LLC a bit to get the desired behavior under adaptive mode. I ended up settling on adaptive mode with 1.24 vcore, a negative adaptive offset of 0.02v and LLC level 5. Without any AVX offset the system behaved exactly as I desired. As soon as I enabled AVX offset -2 the behavior returned. The RING flag was set and the throttling reappeared. Once again, I tweaked various values to no avail (various LLC from 4-7, core/cache voltage values from 1.22 to 1.3ish, power/current limits maxed or at default, MCE, XMP, nothing worked). Manually defining the min/max cache ratios did not correct the problem at all under adaptive mode. Surprisingly, changing the AVX offset to -1 did fix it. This got me thinking.... :).

I thought to myself, a -2 avx offset at 4.8ghz should lead to a 4.6ghz all core turbo frequency when AVX is used. At stock settings, with all bios options at defaults, this CPU defaults to 4.7ghz all core turbo. This 4.6ghz number is below the 4.7ghz number. Sure enough, if I applied a -3 AVX offset at 4.9ghz or -4 AVX offset at 5.0ghz this flag was set as yes and throttling ensued (both at 4.6ghz under AVX). In fact, as far as I can tell, if any AVX offset used with an adaptive OC in the 4.8-5.0ghz range pushes the max frequency below this default 4.7ghz turbo frequency the behavior appears. If the AVX offset does not drop the frequency below this 4.7ghz default all core turbo value it does not occur.

Finally, we get to my question.... Is there something I am missing about the AVX offset that would lead to this behavior? Is there a setting I am overlooking? Or, is it bugged or glitched somehow? Admittedly, a large part of the question is academic. I can work around the issue. I'm just curious if anyone could shed any light on this particular problem.

Apologies for the long post in advance. I figured it would be more helpful to lay out my approach ahead of time.

Level 8
Well I'll be damned. I always knew something was fishy with adaptive; decided to investigate an hour ago and reached the same illogical conclusion.
Luckily, I ran into your post in my very first google search like this: negative avx changes turbo frequencies
Thank you very much, amigo.