cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Z170 Deluxe an Razer Anansi compatibility

Dany_Gee
Level 7
Hello,

I have a strange hardware issue between Z170 Deluxe and Razer Anansi Keyboard.
Scenario:
Turning computer from complete power off (no hibernation) and all my devices except the keyboard are recognized during boot.
Simple re-replug however makes the keyboard work without problems, even after restarts but only till the next complete shutdown. Then the problem repeats itself.

Already checked:
1. Default old bios.
2. Default new bios 1602.
3. All drivers installed and updated.
4. Keyboard firmware updated.
5. Tested on both W7 and W10 (but I think its not a system related issue - I need the keyboard to be active during POST).
6. Keyboard gets discovered during POST on 3 other machines in the house without problems.
7. Old A4tech K126 keyboard gets discovered without problems by Z170 Deluxe.
8. Tested every port (2.0/3.0/3.1, front, back) with other devices connected and with keyboard connected only.
9. USB options in bios tested on/off (legacy mode, XHCI etc)

The only bios option which made a difference was "Advanced Menu\APM Configuration\ErP Ready -> Disabled" - the keyboard gets discovered after power on and the MB even remembers my last LED settings (from Asus Lightning control). BUT, the shutdown is not complete in that case - the LEDs from Kraken X61 and from GPU stay on, what is hard to bare in the night.

Changing the Advanced Menu\APM Configuration\ErP Ready to "Enabled S4" or "Enabled S4+S5" gives a complete shutdown (nothing stays on) but the keyboard is not recognized and LED settings are reset.

Did someone have a similiar problem with that board?
4,223 Views
2 REPLIES 2

Nate152
Moderator
Hello Danny Gee

I'm using the Razer Anansi with no issues on the maximus viii formula. The lights on the motherboard stay on after I shut it down and my keyboard is recognized and working when I start my pc. I have it connected to the usb 3.0 ports on the motherboard, one for the keyboard and one for the lights on the keyboard.

Nate152 wrote:
Hello Danny Gee

I'm using the Razer Anansi with no issues on the maximus viii formula. The lights on the motherboard stay on after I shut it down and my keyboard is recognized and working when I start my pc. I have it connected to the usb 3.0 ports on the motherboard, one for the keyboard and one for the lights on the keyboard.


Thx for the information! Please also check the bios version and following settings in it (if possible):
1. Advanced Menu\APM Configuration\ErP Ready
2. USB Configuration\ (Legacy,XHCI Handoff and PS2 emulation settings)

Either text or screenshots will do 😉

Thx in advance!