cancel
Showing results for 
Search instead for 
Did you mean: 

Asus nvidia GTX 760 OC 2GB DDR5 has display problem.

dipankar760
Level 7
Hi guys,



My ASUS NVidia GTX 760 has a problem, I think. When I am trying to boot the system with the GPU, there is no display at all. When I removed the GPU. the system start without any delay. I don't have a spare GPU to test. I was thinking about the driver conflict. I have tried "Display Driver Uninstaller" programme to remove the NVidia driver in SAFE MODE. It worked, for few minutes my GPU start working. But when I am trying to install the new driver, things are changed. Again the same issue. Everything looks so normal, means GPU fans, power LED on card. I have got only one beep sound after power up. There is nothing at all on display.



Please help me guys. My system specification are mentioned below:


Intel Core i5 4670K @ 3.4 GHZ
ASUS GRYPHON Z97 MOBO
Corsair Vengeance 16GB DDR3 (4GB x 4) @ 1600 MHz
ASUS nvidia GTX 760 OC 2GB DDR5
Kingston 120GB SSD
Western Digital 3.5 TB HDD (1TB x 3 & 500GB)
Cooler Master Slient Pro 550W (GOLD 80+)
Cooler Master 212X
Cooler Master N600 Cabinet
Logitech G19 Keyboard
Dell Mouse
Creative T6160
Dell S2240L IPS Full HD
Windows 8.1 Pro x64

Thank You.
4,166 Views
2 REPLIES 2

Arne_Saknussemm
Level 40
How are you connecting....via what cable...hdmi...DP? have you tried a different cable?

However if DDU got you working until reinstalling display driver....maybe try that again but install older driver not latest?

How old is the PSU?

Min for a 760 is 500w and for an OC card will need more...you are a bit on the edge...I wonder about power....

Arne Saknussemm wrote:
How are you connecting....via what cable...hdmi...DP? have you tried a different cable?

However if DDU got you working until reinstalling display driver....maybe try that again but install older driver not latest?

How old is the PSU?

Min for a 760 is 500w and for an OC card will need more...you are a bit on the edge...I wonder about power....


Hi,

Connecting with HDMI cable. Only once the DDU was worked. I have tried many times. With same PSU, my system was running for the last 18 months with same hardware. My PSU is Cooler Master Silent PRO 550W GOLD 80 PLUS.