cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Crosshair IV Extreme with FX-8370 Vishera CPU (not POSTing?)

zettersten
Level 7
Hi people,

New to the forum. Bare with me as I do not know all the "rules" yet.

For starters... This machine is nearly 4 years old. I've taken care of it all the ways I knew how to.

This passed weekend I decided to redo the water loop.

Like normal water loop maintenance, I simply drained the loop. While the machine was apart I took it upon myself to grab a Vishera CPU at Microcenter.

After redoing the loop and throwing the new CPU in... I was greeted with a non-POSTing PC!

Here are some pictures (:

3046630467304683046930470

Can you guys help?

I've tried everything... I think... I've ordered a new BIOS chip on EBay as some forums state that the motherboard will need some beta BIOS to run that CPU.

Oh... and... My CPU debug LED is solid red. I know that's bad and indicates a number of things... but if not the bios then what else?

Any advice would greatly be appreciated!
218 Views
10 REPLIES 10

Lalau2
Level 7
Hello I would look on the Asus site to see if the FX-8370 is supported by your board. If it is there should be a newer bios you could update and install. Sounds like you haven't updated your bios in a while.

chrsplmr
Level 18
Do you mean 9370?
http://www.asus.com/Motherboards/CROSSHAIR_IV_EXTREME/#support bios 3027
Although that cpu is not listed in the support cpu's under this beta bios, this update
was provide 11/08/11 for the fx's .. and is the last one. The 8350 has been reported
as working with this bios.
What bios is your board running now ?

HiVizMan
Level 40
The CPU works in that board, but I had to update the bios and to do that you will need to use your old CPU.
To help us help you - please provide as much information about your system and the problem as possible.

Poco_OM
Level 10
I heard you can update the bios without a CPU, how gospel that is I do not know, I think the OP has another CPU so maybe a pointless post.

HiVizMan
Level 40
You can do a USB flashback with certain ASUS boards but not the Chrosshair.
To help us help you - please provide as much information about your system and the problem as possible.

zettersten
Level 7
So guys...

I purchased a bios chip from ebay. I'm hoping I can just replace the current chip with this one...

I'll keep you all updated. If all else fails... Right, I'll throw old CPU in updated BIOS and then try again.

Thanks for the heads up and help (:

Uh oh...

I posted the wrong CPU in the title...

I actually own the: AMD FX-9370 Vishera 4.4GHz Socket AM3 and I'm trying to make it work with my Crosshair IV Extreme AMD Board

Sorry!

zettersten wrote:
Uh oh...

I posted the wrong CPU in the title...

I actually own the: AMD FX-9370 Vishera 4.4GHz Socket AM3 and I'm trying to make it work with my Crosshair IV Extreme AMD Board

Sorry!


We know, it happens .. worry not. [just follow HiViz and ur good to go.]
btw..That was/is my favoite board of all time ... so far. I love'd that blinky red thang calling me. .c.

zettersten
Level 7
New BIOS came in today and it didnt work.

I have since thrown the older CPU back into place. Upon booting I verified that the BIOS i got from Ebay was in fact the correct 3027 beta version.

Thus meaning... I 've updated my bios but the CPU still does not post!

What do I do?