cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS 7970 Matrix Platinum Screen Tearing and Artifacts

ArcticV
Level 7
Hello. I've just recently bought the ASUS 7970 Matrix Platinum card, and ever since I got it it's been a pain in the ass. Don't get me wrong, I love the performance and quality of this beast, but from day one I have been getting these weird screen tearings and artifacts. Games become unplayable and sometimes it happend when I'm just browsing with chrome or watch a movie. All temps are good and I nothing is overclocked. I've attached a video to show what it looks like during Battlefield 4.



PS: Sorry for my bad english, I'm foreign.

System specs:
ASUS 7970 Matrix Platinum
AMD FX-8350
ASUS Sabertooth 990fx 2.0
8.0 GB Ram
Windows 8.1 Pro

Any help is appreciated.
36,581 Views
11 REPLIES 11

kkn
Level 14
AMD drivers

Poco_OM
Level 10
Yeah, what drivers are you running currently and are they up to date?
Did you completely uninstall the last GPU drivers?
Failing that:

If possible do a fresh windows install + updates and essential drivers and if it still does it after that I would send that card back.
You could do this in a small partition rather than needing to do a complete system set-up.

I have 2 of these cards and they work great using the 13.9 drivers.

I had lots of issues like this using the beta drivers, so i wiped my pc and installed 13.9 ones which have been fine.

Give that a try, bit of a pain but worth it.
Corsair 900D / Corsair AX1200i / AMD FX-9590 @ 4.7ghz / ASUS ROG Crosshair V Formula Z / ASUS ROG 7970 Matrix Platinum Crossfire / x2 EK Coldstream XTX 480 Radiators / x2 EK 7970 Matrix Waterblock / EK Supreme LTX CPU Waterblock / EK ASUS C5F-Z Waterblock / XSPC D5 Photon 270 Reservoir/Pump Combo / Corsair Vengeance 2133mhz / Corsair Vengeance K70 / Corsair Vengeance M65 / 120gb SSD & 2tb HDD

Croak
Level 7
So...bought a pair of Matrix P's last month, installed them in my trusty P8P67 Pro board, and could not get them to run at over 1100 without artifacting, and even then I had to reduce the memory clocks down to 1500 (6000 in GPU Tweak) or games/benches would rainbow lock in seconds, with Crossfire or without, with one board installed or two, stock CPU clocks or overclocked, with GPU Tweak installed or not, and a clean install of both Windows 7 SP1 and Windows 8.1 on a 840 EVO SSD. PSU is a AX860i, CPU a 2600k (4.4GHz OC), with 8GB Corsair Vengeance Pro 2133 C9, mounted in an Aerocool XPredator ATX-XL case. Drivers used ranged from 13.11 Beta 7 through Beta 9.2, an d the last few WHQL releases as well.

Prior to the 7970's, I was running a pair of shader unlocked 6950's clocked at 900/1300 that didn't give me any trouble.

Yesterday, my Maximus V Extreme and new 3570K arrived (new Battlefield releases always give me an upgrade itch, and the MP's didn't quite scratch it!), so I retired my P8P67 , installed the MVE/i5, and did a "Reset" on Windows 8.1. Did all the usual driver fun, including 13.11 Beta 9.2, installed GPU Tweak, and voila!

Memory is good up to 7000 now at 1.50v! Can get a solid 1275 out of the core at 1.3v! That's in Crossfire, and with the CPU at 4.6Ghz.

Not sure if it was the switch to a fresh CPU over my abused 2600K, better voltage regulation in the MVE, or just the bump up to PCI-e 3.0, but what were cards I was certain I was going to RMA are now overclocking beasts and rock rock rock solid stable and cool at stock clocks. I should mention I'm not using the extra PCI-e power plug found on the MVE, just the dual 8-pin connectors on each GPU, same as it was on the P67 Pro.

Once the shiny wears off my tweaking the new board and chip, I'll plop the 2600k back in and see what the results are...at least that'll narrow it down to either PCI-e 3.0 or an abused, old overclocked CPU.

TL;DR: I no longer blame the Matrix cards for not working as I expected...check your other components, could be one of them is the weak link instead.

bobj151
Level 7
I just got my second Matrix HD 7970 Platinum installed running crossfire ,top card is running fine ,lower card is running at near max load 99% and the VDDC is 1.256 compared to 0-8% VDDC .895 on top card ,GPU-Z shows both cards have the same bios.For about the first 5 seconds in windows 7 the card appears to be normal then the Matrix logo on the side of the card turns purple.I have pressed the safe mode button on the card and nothing happens(stays at the same voltage.) Cards are mounted on a ASUS Sabertooth FX 990 Ver.1 1604 bios AMD FX 8120 cpu. I have uninstalled the drivers ,Catalyst Control Center and tried 309,310 and 311Beta drives and get the same outcome.

Croak
Level 7
Bob, do a Google search on how to disable ULPS via the registry, that should solve your problem, it's a known issue on 79xx cards in Crossfire.

Thank You Very Much!!! It worked ,it was driving me and my son crazy for 3 days!!

Here is a utility to disable ULPS for anyone that has this problem
http://ulps.achromaticcomputing.com/

Just remember, those ULPS settings are re-enabled every time you install/reinstall drivers, until AMD gets around to fixing the problem.