cancel
Showing results for 
Search instead for 
Did you mean: 

Anyone able to help me with a strange memory issue?

AndyAech
Level 7
I can't figure this out. I upgraded from 16GB to 32GB. I bought the exact same memory kit (KLEVV Cras X RGB 3600MHz 2x8GB) to upgrade with. I installed all 4 8GB sticks and cleared CMOS. When I turn my PC on from cold I'm met with an orange dram light on my motherboard (Asus ROG Strix B550 F Gaming) which prevents my PC from even getting to bios. Simply pressing reset on my case clears the dram light and my PC boots up normally.

Why would something like that happen?

I went through the painstaking task of trying each stick in each DIMM slot clearing CMOS every time. They all work fine and there doesn't seem to be any problems with any of my board's DIMMs. I can even have 3 sticks in and everything is normal. But as soon as I put 4 sticks in I get the dram light on cold start.

Here's another weird thing. I thought at first it might be because I was running DOCP, so I cleared CMOS and booted it up. It passed post but when booting into windows I get multiple BSOD errors. I tried again with a manual OC at 3200MHz and got the same outcome. With 4 sticks in I can only run the ram at its rated 3600MHz. Anything else (even stock) I get BSOD. Mainly 0xc0000428. But sometimes also 0xc0000221 & 0xc0000098.

So right now I'm forced to apply DOCP as it's the only thing that doesn't throw up loads of BSOD. I just have to press the reset button to get passed the dram light on cold start-up.

I just don't know what to point a finger at. BIOS? Motherboard? CPU's IMC?

Any help would be brilliant.

Thanks
1,985 Views
5 REPLIES 5

ahfoo
Level 13
This may cause by your ram issue. Even with the exact same model and spec for the ram, two different memory kit might be different in batch production line with different part number. Therefor it better to buy Just a pair or quad pair (4x ram in a single package in you want to occupied the ram slot).

ahfoo wrote:
This may cause by your ram issue. Even with the exact same model and spec for the ram, two different memory kit might be different in batch production line with different part number. Therefor it better to buy Just a pair or quad pair (4x ram in a single package in you want to occupied the ram slot).


They're all the same ICs (Hynix djr) so there are no mismatching shenanigans going on. They work well together, even 3 sticks work perfectly together, but as soon as I put all 4 sticks in and I get the above-mentioned problems.

Murph_9000
Level 14
AMD treat 3 sticks as a dual bank region and a separate single bank region, but 4 sticks will be a single dual bank region.

Superficially identical sticks that are bought at significantly different times may well have subtle differences in the underlying silicon. Have you tried loosening the timings a little (i.e. keep the clock that seems to work, and increase the timings, e.g. from CL16 to CL18, etc).

Remember that 4 sticks of overclocked RAM is always harder to support than 2 sticks (on dual channel platforms).

You seem to be saying it works ok at 3600? Or is there some problem at that speed?

Murph_9000 wrote:
AMD treat 3 sticks as a dual bank region and a separate single bank region, but 4 sticks will be a single dual bank region.

Superficially identical sticks that are bought at significantly different times may well have subtle differences in the underlying silicon. Have you tried loosening the timings a little (i.e. keep the clock that seems to work, and increase the timings, e.g. from CL16 to CL18, etc).

Remember that 4 sticks of overclocked RAM is always harder to support than 2 sticks (on dual channel platforms).

You seem to be saying it works ok at 3600? Or is there some problem at that speed?


No. The only problem I have at 3600MHz with 4 sticks installed is that I have to press reset once I turn on the PC from cold to get it to pass post. Once that's done it runs fine. It's at every other frequency that it gives me no problems booting up but instability BSOD errors.

I'm starting to think it has something to do with my CPU and the motherboard's topology.

TBH, I'm just going to admit defeat against this one. Nobody seems to know why it's doing the weird things that it's doing. I've spent weeks trying to figure it out and I've got nowhere. I'll return the kits I have and go with a 2x16GB kit from Corsair. At least I know this motherboard and CPU work fine with only 2 DIMMs in use.

Silent_Scone
Super Moderator
Hello,

Memory kits are binned in the density they are sold in. A common misconception is that one can combine two or more of the same memory kit PN. Unfortunately this not the case, neither memory or motherboard vendors support or recommend doing this. You will need to return one or more of the kits and purchase a single kit to ensure best chance of plug and play compatibility.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090