cancel
Showing results for 
Search instead for 
Did you mean: 

Again, a strange problem

EnthusiastBuild
Level 12
Dear ROGers

And again I am having a strange problem.

About a month ago it started. Everytime Windows 8.1 makes an update and i restart my PC, keyboard and mouse (Razer Blackwidow, Razer Taipan USB both) will work in BIOS but as soon as the login screen comes they power off and I can't type anything.

I always have to set back my system via recovery and then it works again.

What the heck is this, I googled and googled but found no solution for me, I hope someone here can me help, it is freaking me out.

Sincerely

EnthusiastBuild
CORSAIR 900D
ASUS MAXIMUS VI FORMULA
INTEL I7 4770K @ 4.5 GHZ
CORSAIR DOMINATOR PLATINUM 16GB @ 2400MHZ
SLI EVGA GTX 780 SC ACX
SSD SYSTEM: CORSAIR FORCE GT 120GB
SSD APPS: CORSAIR FORCE GT 240 GB
HDD STORAGE: WD BLACK 2TB
CORSAIR AX860I PSU
CORSAIR H100I 4 x SP120 HP
159 Views
23 REPLIES 23

HiVizMan wrote:
Based on the enquires I have made there seems to be a known issue with the Razor keyboards and mouse, if possible could you test with a generic keyboard and mouse just to isolate if it is that specific product that is causing the issue.


Bluffableyew wrote:
Just a thought, assuming u are using them off Mobo ports at the back, try the front side or vise verser to rule out the USB hub issues


I did check with a Steelseries mouse and a logitech Keyboard. It happens as well. Very strange, because before everything worked fine!

Yep, im using the mobo ports at the back, and i tried the ones in the front without success. Example: Again mouse and keyboard does not work on login, shut pc down, put mouse and keyboard in the front ports.
CORSAIR 900D
ASUS MAXIMUS VI FORMULA
INTEL I7 4770K @ 4.5 GHZ
CORSAIR DOMINATOR PLATINUM 16GB @ 2400MHZ
SLI EVGA GTX 780 SC ACX
SSD SYSTEM: CORSAIR FORCE GT 120GB
SSD APPS: CORSAIR FORCE GT 240 GB
HDD STORAGE: WD BLACK 2TB
CORSAIR AX860I PSU
CORSAIR H100I 4 x SP120 HP

HiVizMan
Level 40
A few Logitech have the same issues G15 I think is one such.
To help us help you - please provide as much information about your system and the problem as possible.

EnthusiastBuild wrote:
It still happens, is there a way to reset all the usb?

Did u try in safe mode F8 ?

Bluffableyew
Level 7
Well I know of HDD issues that can cause these types of problems, if u can,I suggest to swap the system hdd & install fresh copy of windows & try, also get the latest drivers from the site too