Showing results for 
Search instead for 
Did you mean: 

Z170 PRO GAMING Not recognizing Logitech G510 RGB after new BIOS update

Level 7
Title says all.

Windows 7 64bits + Z170 ISO Patch for USB devices (Install, etc)
ASUS PRO GAMING Z170 (With latest BIOS,sadly)
Intel i7 6700K stock clocks
2x8GB DDR4 2133mhz (same brand)
2 SSDs + 1HDD
GTX 970
Logitech G510 RGB Keyboard

Today i wanted to update my Z170 PRO GAMING's BIOS to the actual latest version. Once i've done that, i can reach Windows 7 (before and after a format) without issues, but if i want to access to my BIOS, I CAN'T... Del key, F2 key.. Nothing

I've unplugged all SSDs+HDD and i could get into the BIOS, but guess what?

-Legacy USB is set to ENABLED
-XMPC or whatever it's DISABLED (If enabled, Mouse, a Logitech G502, won't work AT ALL)
-All USB 2.0 3.0 and 3.1 ENABLED

The BIOS update killed my way to mod things from it or even allowing me to choose any Pre-Windows 7 booting error option ("Start normally", "Start booting repair mode" or something) by using the KEYBOARD.

However, using someone's way older, wireless Logitech Keyboard for casual life (NOT gaming) ....Worked?!...Both HIS KB (with Wireless receiver that has no drivers installed and worked 1st time) and MY KB (Direct USB plugging) can be connected but mine can't get into BIOS and HIS CAN GET IN?...Maybe it's because mine has lights once i press the tower's power button.

Obviously, i want to use my G510 for all..And don't want to change it at all.

Yes, i've tried changing to another USB 2.0 and even 3.0 Ports but to no good results.

Obviously it seems i can't downgrade the BIOS because it's in a 3### version and no FUEFI or whatever program for Windows can't do the job anymore because "It blocks it"...And worse of all, it could destroy my Motherboard.

What can i do?. I tought of getting a replacement at a shop, with the same Motherboard or the newest Z170 PRO GAMING AURA, wich's the same board but with side RGB colors.. The question is, incase i end up buying a new one:

1.If i buy the original Z170 PRO GAMING, will it come with it's initial YEAR 2015 BIOS?...Or will it come updated to the latest or not so latest?

2.If i buy the NEW Z170 PG AURA... Will my Logitech G510 keyboard work on the BIOS WITHOUT UPDATING AT ALL?..

Please help me out.. I have 9-10 hours (Sleep time) before heading to the city and i need an answer with possible solutions..

Thanks in advance..

Level 7

I got exactly the same problem. Entering and navigation BIOS with my G510 went fine on 2003, then I upgraded it to the newest BIOS and its not working anymore. Are there any solutions?

Level 7
Check if ErP is enabled in any states (Advanced tab > APM Configuration > ErP Ready).

Hey, thanks for your answer.

It was already disabled and temporarily changing it to Enabled didn't help either. Any other ideas?

I had the same issue G510 will not work at boot only in Windows. I ordered a replacement bios chip with an older bios and it is working again. I notice there is a new bios out so it could have fixed the issue but I aint flashing it to find out as Asus in all their wisdom blocks bios downgrades to different string bios.:rolleyes:

F. Gacrux wrote:
Check if ErP is enabled in any states (Advanced tab > APM Configuration > ErP Ready).

How do you want him to check if that is enabled or something if he can't go into the BIOS?..