cancel
Showing results for 
Search instead for 
Did you mean: 

x570-f Bios pcie slot fail

Simplysimon911
Level 7
hello.

i updated my bios from 1407 to 2203 and now 2407 on my Asus x570 - f. After the first update i lost use of by Inatech usb 3.0 card inserted into PCIE_x1_2 so i contacted ASUS who told me a newer bios was available so again I updated. Still no fix. Their next response was to RMA the board which seemed very extreme and defeatest. I attempted a flashback which failed using 4 different USB sticks all formatted to FAT 32 which was a waste of time as this function doesn't seem to work either. Eventually the card did show up in device manager under hidden devices. I tried the card in another win 10 pc and it worked flawlessly as it did before the updates. I have tried setting the bios for the pcie_x1_2 lane to gen1,2, 3 and 4 with no success. I just cant understand why a bios update affected the usb expansion card. I have now formatted Windows now and still no fix and further more i have carried out quite a few trial and error changes with no fix.

Asus x570 - f bios 2407
Amd 3700x
Asus rog strix 5700xt
32gb corsair ram
corsair 750w psu


thanks in advance
752 Views
0 REPLIES 0