Showing results for 
Search instead for 
Did you mean: 

[X570-E Gaming] Elgato Cam Link freezes under CPU load

Level 8
Hey guys, I have a very weird problem with my X570-E Gaming motherboard and Elgato Cam Link.

I have used the Cam Link before with my X470 Crosshair VII Hero but upgraded to the X570-E Gaming as I needed/wanted access to PCIe 4.0 (Crosshair VIII Hero here is $100 more expensive than in the US and that is without VAT whereas the X570-E Gaming has roughly the same pricing as in the US...)

I am using a Canon EOS RP through an Elgato Cam Link.

Today I have a Teams meeting and notice that my camera freezes immediately when I join a call or if I go to settings and check the preview. It's always a frozen image from RIGHT when I opened the setting or activated the camera in the call.

Aside from the Cam Link I have a Microsoft LifeCam Studio connected to my PC. I made sure they are not on the same USB Root Hub.

When the Cam Link is attached to the X570 Chipset USB Root Hub: All cameras work perfectly fine outside of Microsoft Teams. They work fine together in a scene in OBS, they work fine in Microsofts own Camera app, they work perfectly fine in Microsofts own Skype for Business suite, they work in Discord.

When I open Teams the Cam Link freezes, my webcam continues to work though.

When the Cam Link is attached to the CPU USB Root Hub: all cameras work fine outside of Teams, same behaviour in Teams as when it's connected through the chipset. However, if I start a stream or put my CPU otherwise under load the camera freezes instantly or within about a minute in any app.

What I have tried so far:

- used USBDeview to remove all disconnected devices, then removed all connected devices too

-uninstalled and reinstalled Teams

-uninstalled and reinstalled Teams with deleting all Teams folders within AppData

-checked the integrity of the windows image and installation using DISM and SFC

-uninstalled and reinstalled every capture device (Cam Link, LifeCam Studio, Elgato 4K60 Pro II)

-uninstalled and reinstalled capture software (Elgato 4K Capture Utility)

-uninstalled the OBS Virtual Camera plugin

-ran Windows update, installed optional updates for Webcam (LifeCam Studio is then in the device manager under Imaging Devices and not Cameras anymore)

-removed all NDI plugins from OBS and Windows

-changed USB BIOS settings, reset BIOS and used optimised defaults, tried BIOS 2816 and 2802.

No change in behaviour

I also reinstalled OBS again and tried OBS Virtual Camera in Teams (Cam Link on Chipset port) and then I can get my Cam Link picture into Teams without freezing.

This is all very weird and I am wondering whether or not I have a defective mainboard or whether this is a known issue. All other USB devices, as far as I can tell, continue to work fine while on the CPU USB Root Hub and with the CPU under load.

Level 8
After wasting about 8h on this trying every fix I stumbled upon a small thread on reddit describing USB stability issues. I have switched my GPU PCIe from Auto (Gen4.0) to Gen3.0 and the issue disappears. This seems to be an AGESA issue and AMD should know to address the issue in an update.

Level 8
After wasting a lot of time on this I stumbled across a small post on reddit about Gigabyte motherboards having issues with USB, that was later edited to include AMD. I assume this is an AGESA issue. Switching GPU PCIe from Gen4.0 to Gen3.0 fixes the issue completely.