Showing results for 
Search instead for 
Did you mean: 

X570-E Gaming -- Audio Doesn't Work, Kinda

Level 7
So having an issue with this new build on my x570-e Gaming. I can't figure out if it's windows 10, Realtek, or something with my mobo.
Occasionally I'll get it working after uninstalling and reinstalling the same driver repeatedly and running "windows troubleshoot" repeatedly but it only works arbitrarily there is never a rhyme or reason or even order of operations that when repeated produce the same results.

I have Mackie CR-X computer speakers and they work, they also work on my phone, but won't work when on my pc. Headphones however have worked while the Speakers don't work on my pc but again only arbitrarily, sometimes yes sometimes no and for seemingly no reason.

The Realtek Audio app/manager/hub when installed will ask "what type of audio device" i plugged in, then after answering ask the same thing several more times. Or sometimes only the once, again arbitrary afaik.

The few occasions I've had the sound working I've had the realtek audio drivers and the hub installed, and completely uninstalled so again......arbitrary.

When they're working it's fine, for all of a few hours then out of nowhere they just stop. Nothing is plugged in or taken out, no programs are started or stopped, just in the middle of gaming and it goes kaput.

If anyone has any insight that'd be helpful, otherwise I might just install windows 7. Because I'm pretty sure this is a win 10 issue since win10 is notorious for Audio problems. But I have a key for win 10 so I'd prefer to keep using it.

Been at this for hours and hours and can't find or produce a single real solution

Level 7

i was getting issue of no sound. i tried all solutions over the internet but nothing worked.  Reinstall realtek audio drivers many time but never worked.finally rebooted in safe mode and then rebooted in normal mode. And sound started working. i think it was the IRQ conflict issue. probably two devices were sharing the same IRQ. since safe mode boot does not load any drivers and released the conflict of IRQ. in next reboot all devices got new IRQ.