cancel
Showing results for 
Search instead for 
Did you mean: 

X370-PRO New M.2 Drive Not Listed

09Kr0058
Level 7
I'm replacing the the 512gb Samsung 960 Pro M.2 drive on my X370-PRO with a new 1tb 970 PRO. I plugged the 970 into a USB adapter, did a clone from the 960, shut down, removed the 960 and installed the 970.
When I boot up hitting the DEL key and go into the BIOS to select the startup drive from the main screen boot-order section, the 970 is not listed. However, if I boot up and hit F8 to get the boot menu, I can select the 970 there and it boots fine.
How do I get the new drive to show in the boot-order section?
1,881 Views
5 REPLIES 5

RedSector73
Level 12
Your old drive you may not have setup to use or it didn't use UEFI & secure boot, the new one does.

Other possible causes nvidia firmware update for graphics card but you have not listed your system thus who knows.

I am guessing that because you cloned to the new SSD through a USB port, the UEFI boot manager program doesn't recognize it as a Windows boot drive through the normal booting procedure. By using F8 you are essentially manually booting to the new SSD as if it were an externally attached USB drive. When I've cloned a system boot drive to a new SSD, I first used Acronis True Image to make a system disk image to an external USB-connected drive. Second, I installed the new unformatted SSD in the computer. Third, I then cloned the externally-attached disk image back to the new internal SSD from the Acronis backup. As you know, Acronis is commonly used as a cloning tool but there are others such as Macrium Reflect. You might try cloning the new SSD over again by using your cloning software to first make an external USB-attached image and then cloning it to a new internal drive as I've described. Good luck and let us know how you solve it. Here is an excerpt from the Acronis manual that suggests this procedure.
89569

09Kr0058
Level 7
Thanks for the replies.
This morning I tried putting the original M.2 card back in the slot and I get the same thing! The BIOS boot order doesn't show the 960 which had been in there for about 2 years, but I can still boot it via F8. Does this make any sense? Is there someway to do some kind of refresh to have the BIOS boot order update its list?
I used Macrium Reflect to do the clone. I had some issues with Acronis back around 2014. I then tried Macrium and have had a full license ever since.
I have a removable hard drive bay in my machine. When doing backups, I put a 4gb 3.5" WD Black SATA hard drive in it, boot up the Acronis backup ISO from a USB drive and backup to the HD. Yes, I know backups can be done while Windows is running, but I prefer to do the backups this way.
I just can't understand why the BIOS isn't seeing the M.2 drive, when it has worked fine all along.

Sorry you are still having this problem. Maybe RedSector3 was onto something with the suggestion that the old 960 and new 970 SSD are set up differently perhaps with respect to legacy booting (with MBR partition) versus UEFI booting (with GPT partition). If your BIOS is set up for the more modern UEFI booting, but the 970 somehow got cloned with an MBR partition for legacy booting, then it won't show up in the boot priority list within UEFI BIOS. Usually in UEFI the boot device shows up as "Windows Boot Manager" or "UEFI: Samsung 970 Pro" or similar rather than just the hardware name. Also you may know that for UEFI booting you have to disable CSM (Compatibility Support Module) in the BIOS as that is used for legacy boot devices that may be partitioned MBR. You could go into BIOS and verify that you are using UEFI booting, and also verify that the new 970 is using GPT partitioning. If both true, then make sure CSM is disabled. See if you can find "UEFI: Samsung 970 Pro" or similar in the boot list.

If everything looks right in terms of using UEFI booting, you could boot using F8 (the 970 SSD, for example) and go into the Windows Disk Management Console as Admin. Your boot drive should be in the list. Say the Windows partition has drive letter "C", then you should see something like this:
89587
One of the parameters for the "C" partition should be "boot". If not, right click and see if you can mark the parttion as "active". Have everything backed up of course.

I just remembered that your said putting the old M.2 (960) back into the computer, you still can't see it in the boot priority list and have to use F8 to select it. Whereas before there was no problem booting from the old M.2. Sounds like something may have been changed in BIOS? For example, did CSM accidentally get enabled? If so then I don't think the BIOS would allow UEFI booting from a GPT-partitioned boot drive. Just a wild guess and out of ideas.