cancel
Showing results for 
Search instead for 
Did you mean: 

Win 8.1 / USB Error / No wake up after screen lock / State b2 / Fastboot failure

kuzzi
Level 7
Hi all

I’m a forum noob and German language native, so plz no bashing around 😉 – but I’m always open for constructive feedback. 😮

Ok, here we go


Situation:
- A hell of a lot of ASUS boards (I hate and love them) are messing around with Windows 64bit editions and with themselves and unfortunately also with other ASUS products like graCards etc.
- An Issue named Windows – on desktops of the world since 1-3-1992


Details:
- USB unknown device “descriptor request failed” error on one device -> still no solution found instead of exchange with a revised built (maybe)
- Fast boot issues (no fast boot available – power errors)
- No or very slow coming back from sleep mode after (“WINkey-L”) lockscreen
- And many more (I only take the main things happened to me and how things went better after weeks of analysis

My rig (just for tech info):
- ASUS Maximus VI Extreme Rev. 1.xx
- Intel I7-4770 3.5Ghz -> OC to 4.0Ghz
- 4x8GB Kingston 2400Hz beast -> runs with UEFI/bios 1603 only on 2133Mhz – before it ran on 2400Mhz without troubles
- GPU ASUS GTX780TI-DC2OC-3GD5 x1
- LG 34um95-p on Display port with original factory cable
- Corsair RM850 PSU
- IN WIN Tou case CPU air cooling “be quiet dark rock pro 3”
- Logitech G710+ and Mad Catz R.A.T.9
- LG Bluray drive (have many older games – still need it)
- Windows 8.1 with permanent running AI Suite 3 / AIDA64 / Steam / Origin / Acronis True Image / Kaspersky AV
- Specials: Nvidia PhysX Legacy drivers / nGlide 1.3

Painpoints, solutions and analysis (found in the net and brought together, some I found myself):


1. Updated to Windows 8.1 – the opposite of a solution - it was causing the most errors, but a step back is no acceptable solution for me. Some were happy with getting back to Win 7 / 8 – for me that’s just a temporary workaround.
Better watch out for updates that Microsoft calls back and re-release. Be sure you always have the re-released patches. Also watch out for optional updates correcting Win errors.

You can check if Windows is ok by entering those commands in a Command promt with admin rights (can be opened by right click on start button):

--> DISM.exe /Online /Cleanup-image /Restorehealth
--> sfc /scannow --> still working http://support.microsoft.com/kb/310747/en

- other repair options: https://www.winhelp.us/repair-your-computer-in-windows-8.html
- my main thing: system protection enabled and working with restore points -> http://www.dummies.com/how-to/content/restore-from-a-restore-point-in-windows-8.html

-> there is an endless list how you can sail around a fresh Windows installation. There are also repair and refresh tools… Sorry, I don’t have good English links – most are in German

Best thing to figure out windows problems is working with the event logof the OS. This can be found by right click on start button – here you can see your boot info, too.
But be careful of false positives. Most important events are “Criticals”. Google around with the messages and you will find a lot of good information on your failures.
There is also an addional debug mode - but I never tried it. With that you can get more logs.

A lot of errors are caused by old, incompatible or several times updated drivers and bodys rotting in the registry – registry can be opened by WINkey-R and entering “regedit”. Better to make a restore point before changing the registry.
Drivers and utilities can be found in the device manager and some are shown in the “programs and features” list. Very helpful also for uninstalling or repairing.


2. Failure #1 - Unknown USB Device (Device Descriptor Request Failed) Code 43 – tried almost everything and still no solution found.
It happens from time to time and sometimes can be solved by uninstalling it in device manager and searching for changed HW -> sometimes after 1-5 times it it’s ok until the next error. But the USB devices are working for mass storage – not for things like a mouse or an iPhone. Still no solution for this.
For some people it worked when they plugged off all unnecessary usb devices, uninstalled every USB device in the device manager and rebooted the machine. They should all be reinstalled by windows.

There is also a driver for ASUS Maximus VI Extreme:
http://www.asus.com/Motherboards/MAXIMUS_VI_EXTREME/HelpDesk_Download/
Could also be a physical or a energy related issue…


3. Failure #2 - Monitor no or slow wake-up after locking the screen (WINkey-L) - After a lock of the screen there is an additional energy setting hidden in the registry that is responsible to turn out your screen after 1min. This can only be changed in the windows energy options (right click on start button) after changing a registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7

Attributes DWORD
1 = Hide "Console lock display off timeout"
2 = Show "Console lock display off timeout"
http://www.eightforums.com/tutorials/8267-power-options-add-console-lock-display-off-timeout.html
and
http://www.eightforums.com/tutorials/8268-lock-screen-timeout-period-change-windows-8-a.html

My Issue was related to – not a windows issue – the graphic card! Everytime when it had really NOTHING to do – the graphic card driver was crashing because of a lack of energy I suppose.

Here’s the event from the windows event log – came every time after screen lock:

Der Anzeigetreiber "nvlddmkm" reagiert nicht mehr und wurde wiederhergestellt.
Display driver nvlddmkm stopped responding and has successfully recovered


Sometimes I had to wait 30sec to 1min until it recovered. Sometimes I had to force a reset. It was so annoying…
I found a lot of hints in the web to change the NVIDIA energy settings and so on -> some can be found here: http://www.instructables.com/id/How-to-Fix-the-Nvlddmkm-Error/?lang=de

But for me I like running the system on adaptive, a bit energy saving settings. Don’t wanna waste energy. My footprint is large enough…

My solution was:In GPU Tweak of ASUS V 2.7.5.0 I increased the minimum voltage to 975mV on 1020Mhz clock. Since then I have no more errors regarding this failure and the lockscreen was 100% easy to wake up.
For now I’m running the settings like this – without any error and a base temp of 30-34 degrees:

45435
45436

However, GPU is monitored as running in desktop mode on 887mV or jumping to 975mV, but never goes under 887mV – I think it is a feature of the adaptive energy mode of the Nvidia system settings or ASUS controlled - no idea.
Under gaming stress (100% GPU usage) the monitoring shows over max around 1162mV and a temp of around 76-77 degrees max – no errors.

45437


4. Failure #3 - State “b2” MB Q-code (not “62”) on startup and no further action – workaround is to push the reset button when it appears. But it never appeared again after solving point 5 failure #4 in this post.


5. Failure #4 - Fastboot issue after regular shutdown - I found Windows events showing this during shutdown and startup (not reboot):

-> Kernel Power Error Event ID 41
Das System wurde neu gestartet, ohne dass es zuvor ordnungsgemäß heruntergefahren wurde. Dieser Fehler kann auftreten, wenn das System nicht mehr reagiert hat oder abgestürzt ist oder die Stromzufuhr unerwartet unterbrochen wurde.
Type: Critical Category: 63
Event: 41 Source: Microsoft-Windows-Kernel-Power
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

-> This is something that shouldn’t happen because when energy turns off, then the hibernate mode of Windows is interrupted and therefor no real fastboot is possible after it. (You can force it by UEFI/BIOS)
When fastboot is successful, then it shows MB Q-Code 40. If it’s a normal boot (after energy loss) it shows AO.

this is the most not-understandable thing for me, but the solution for me was this:
Looking for the value “AppInit_DLLs” in registry under HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Windows

-> value of the REG_SZ was: “C:\PROGRA~2\NVIDIA~1\3DVISI~1\NVSTIN~1.DLL”
---> this file doesn’t exist!!
-> changed the value it to “0”
-> See MS KB: http://support.microsoft.com/kb/197571

Finally my main-errors during the Windows 8.1 / ASUS odyssey. It’s a long way to the top if you… the rest is history. 🙂


Important notes:
- I use CPUID CPU-Z, GPU-Z, MemTweakIt, AIDA64, ASUS PC Diagnostics 1.3.4 and mainly the Windows event log for analysis.
- I use several newer generic drivers for
-> Intel chipset
-> Intel Management Engine components (10.0.30.1054)
-> Intel Network Connections 19.5.303.0
instead of the older versions that are officially linked on the ASUS support page.
https://downloadcenter.intel.com/SearchResult.aspx?ProdId=816〈=eng
Official drivers can be found here:
http://www.asus.com/Motherboards/MAXIMUS_VI_EXTREME/HelpDesk_Download/

- I use ASMEDIA
-> ASM104x USB 3.0 Host Controller Driver 1.16.18.16034
-> ASM106x SATA Host Controller Driver 1.3.4.001

- I do stresstests by Intel Extreme Tuning utility and Benchmarks with 3Dmark11 for checking the components.


Note: I’m not related to any supplier nor can take responsibility of the above mentioned solutions. Do changes on your system at your own risk 😛

If there is anyone who can help me with this USB descriptor error – I’d be very thankful! 🙂
3,260 Views
0 REPLIES 0