cancel
Showing results for 
Search instead for 
Did you mean: 

win 8.1 issue i think

evilmustang66
Level 10
so I am running my max v extreme actually running since 4 rmas later and sent a brand new replacement for the hassle

I reinstalled my win 64 8 pro os finally got in and went to upgrade to win 8.1 through the win 8 staore as I hit the download and install I downloaded all the 8.1 drivers from the asus support site but it refuses to install the intel chipset drivers but yet no devices are missing any one else have issue with the upgrade cause when I vist the intel download site it shows nothing like the chipset isn't even installed didn't have this issue with win 8
184 Views
3 REPLIES 3

HiVizMan
Level 40
Since you did an upgrade there is no need to do anything with the drivers. I have done three systems the last twenty four hours and not one of them required a driver to be installed.
To help us help you - please provide as much information about your system and the problem as possible.

my system crash so bad with the 8.1 update, first the xonar pheobus then the asus 770 display not working.
i lost my restore point during the upgrade. I have to do a fresh install of windows 8.1. to get asus 770 working again.
i give up on the xonar phoebus using on board sound right now.

i am using maximus v gene 🙂

evilmustang66
Level 10
well talked to ms finally they decided to give me a 8.1 pro 64 bit copy free since the update had bugs and was not functioning properly also lost all my data cause the os wipe the drives when it clearly marked for the c drive that had the os only and ms is a pain in the rear to deal with they are far more worse than asus in a rma dispute thanks for the help hazman I ran firefox and the intel site worked fine but I was told the os might of carried win 8 issues over