cancel
Showing results for 
Search instead for 
Did you mean: 

Very weird problem (pcie, videocard, mobo) pls help!

cleverleyson
Level 7
I've just installed an Maxi iv Gene-z/Gen3 a few hours ago with an i5 2500k with an Sapphire 6950 1gb with an Zx series 850w psu and i've seemed to have come across a little bit of a headache, Its to do with the Sapphire and the pcie slots, They just won't talk to each other the gfx's fans are spining so its getting power and if you take the the pci cables out the videocard the fans still spin and the red no power light comes on so its getting power from the port, i've also tried it in my old Asus Amd board and its fine and posting, and to make matters worst my old ati X19500xtc(i think) works in both slots on the board so they are working too.

I've also tried moving the dvi cable around to diffirent ports on the videocard and booting the system up up to see if that works, I've also used an hdmi cable and it only seems to work on the onboard igfx port. Which i'm using now.

I've also double checked to see if the videocard was seated well but it seems fine and the power cables are in. I also tried another PSU to see if was power related.

I just wondered if you chaps have come across this bug before and maybe there is a fix, which would be lovely.

Also thank you for any help you can give.

If there is any more information you need let me know.

this is my videocard
http://www.sapphiretech.com/presentation/product/?cid=1&gid=3&sgid=1041&lid=1&pid=1271&leg=0

this is the psu i'm using.
http://www.ocztechnology.com/ocz-zx-series-850w-power-supply.html
7,709 Views
13 REPLIES 13

ColonelS
Level 9
wait you are saying that your 6950 will still run with fans spinning even if there are no 2x6pins power attach to it?
Click ->Republic of Gamers<- official Facebook page

yeah, its basically its telling that there isn't enough power going to the card and a red led is shown on the card and the fans spin up quite loud (this is all from the port power) as soon as i plug them in (system off) the led goes off and the fans act normally.

luckly im a ICT techie so i like to test.

Yeah already updated to the latest bois (one that just came out) might be worth reflashing it when I get back from work. Im quite happy that it isn't any of the parts, Maybe its just a bad combo. could it be that the gpu is taking too long to wake up so bios might be missing it?

I was thinking of a way of testing this maybe setting up another psu that is on and powering the gpu and then start the system.

At this rate i'll end up getting a new gpu, i just want to know if i go down that route it won't happen with the new gpu.

Still early days, Its keeping very busy after work which is funny seeing i do it as a job!

thanks for you help!

another question, would a dvi-d (single link cable) be the issue maybe? should i try and get a full on double link cable. Also My videocard has two dvi ports, one hdmi and one dp?

Again thank you for your time

HiVizMan
Level 40
If your PCIe slot is working, and you say you tested and got picture from the other cad then it is.
If your graphic card is working and you have tested it and got picture on another system and you have then the card is working.

The only thing I can suggest right now is go into BIOS and do the following.

F5 enter
F10 enter

If the card is not picked up, flash to the latest bios and that might jump-start the card recognition.
To help us help you - please provide as much information about your system and the problem as possible.

HiVizMan
Level 40
A really good thing to test is the PCIe connectors often they are not providing the full requirements. What I do is take one of the adaptors that we all have laying around and connect it to the 4 pin molex and use that. Ideally a multi meter of course.

It just could be that if you have many devices drawing from that rail it can not cope. But that does seem unlikely on boot up.

Re the bios flash. A good idea as there might be a touch of corruption and a reflash will sort that out.
To help us help you - please provide as much information about your system and the problem as possible.

Spathi
Level 9
You might want to check if Gen3 works with Gen3 yet, maybe Intel have not released all the updates yet. (Gen3 needs a special update, you might have that update, but maybe it also needs a microcode update in firmware to work properly)
Given Gen 2 works my guess is the card somehow thinks it can run as Gen3, but there is no Ivy (but I have no idea, Asus would know more).

Unfortunately Ivy is delayed which may also be needed, if AMD or ASUS can't fix it.

HiVizMan
Level 40
7950 is backward compatible, I have tested on MIVE boards with 3 of them and all is good. True that does not mean the cards will work on all boards. But they should.
To help us help you - please provide as much information about your system and the problem as possible.

Its deff the videocard, Just had a go at putting it in a p8z68-v lx and it did the same thing, Maybe having it in a Amd system for a while effects it? crazy stuff anyway ive got a new gene-z coming and i bet it will do teh same thing. time for a new videocard i think, I might give AMD/ati a miss this time.....Just to be safe!

Plus pretty sure tehj 6950 is gen2 😄

Thanks for the help!

Quick question about Dvi and HDCP


Im currentley using a DVI-D (single link) only one i could get my hands on, My card has HDCP all over it, would i double link be needed for HDCP? It was made by intel.
http://en.wikipedia.org/wiki/High-bandwidth_Digital_Content_Protection
Your thoughts would be lovely.

same problem with the card in an p5w DH (core duo) very odd. thats three mobos it won't work in all intel.

Just ordered a 7950. hopefully this is end this mind ****!