Showing results for 
Search instead for 
Did you mean: 

Vanguard B85 won't boot from USB flash drive

Level 8
Hi All,

I recently purchased a Vanguard B85 to upgrade (and downsize a little) an ESXi cluster I've been running at home for a couple of years now. The Vanguard B85 with a Core i5-4670K runs ESXi 5.5 just fine (with the addition of an Intel 1Gb Ethernet adapter). The trouble is that I just can't get this board to boot from any of the USB flash drives that I have. Full hardware list is as follows:-

Asus Vanguard B85 with BIOS 1803
Core i5-4670K
32 Gb RAM - 4 x 8Gb Team Elite 1600Mhz DDR3
Intel PRO1000 PCI-E NIC
Broadcom dual Gigabit NIC / iSCSI adapter

I'm not using any local attached storage in my ESXi hosts - all storage is provided by an iSCSI SAN

I've tried two different SanDisk USB flash drives - Ultra 16 Gb (USB 2.0) and Ultra 64Gb (USB 3.0)

Obviously I've flashed the BIOS to the latest version, tried both types of flash drives in both USB 2.0 and USB 3.0 ports and no matter how I set the BIOS it just won't boot from the flash drives. I can hook-up a hard disk and install Windows 8 and boot from that, or from a USB attached DVD-ROM drive, works perfectly. However, every time I try to get it to boot from a USB flash drive I can see lights flashing on the USB device (like it's reading it) but after a short while it just goes straight into the BIOS screen - no errors or anything. What I can do is boot the Vanguard B85 from an ESXi 5.5 installation DVD and use the "boot from local storage" option in the boot-loader and it will read the USB drive and continue to boot and run ESXi just fine - but obviously that's less than ideal.

I've got plenty of other ASUS boards at my disposal (including a RIVE with i7-3930K and an older Sabretooth X59 with an i7-950)) and I can make ESXi 5.5 boot from the USB even on a low-end board like the P8H77-Pro with an i7-3770K, using the same RAM and USB drives and it boots from USB absolutely fine - so I know my USB devices are good and the install method is sound (I work professionally with ESXi, I'm very familiar with it).

If I boot the Vanguard from an ESXi installation DVD but run ESXi from the USB it runs fine and I've had it running 7 or 8 virtual machines with no issues over a 72 hour period.

This is hugely frustrating and I'm considering RMA'ing this board - I don't think there's a fault as such, because the board runs absolutely fine in all other respects, but if the board won't boot from some of the most commonly available USB drives then it's effectively 'not fit for purpose'.

Is there something I'm missing? I've tried just about every USB setting combination on offer in the BIOS and there are loads, the BIOS is needlessly complicated.

I bought this board because I don't need the features of a Z87 chipset, I'm not overclocking, not using any SATA drives, and just building a reasonable spec, sensible priced ESXi host using a chipset and CPU combo that I know works. I went for the Vanguard because of the reliability offered by the TUF line of motherboards, it's compact micro-ATX form-factor, and the fact that it still has 4 x DIMM slots. I've been running ESXi on an X59 sabertooth with an i7-950 for ages, but it's a power-hungry thing with a limit of 24Gb RAM and so I want to get both my ESXi nodes running with mid-range, more efficient, Haswell CPU's.

Do I RMA this board, or is there more firmware on the way?


Level 8
Update - I contacted ASUS support via email and was advised to RMA the board. So, believing that the board is faulty I've now bought an advanced replacement of the same board and guess what .... the same problem.

The allure of this board is that it's appears to be a high quality board (TUF) that will support 4 x RAM slots for 32Gb RAM, uATX and has an Intel onboard NIC. It's a very attractive proposition for building a diskless, compact ESXi server, but don't waste your time because you can't boot from USB flash drives - time to look for a different vendor.