Showing results for 
Search instead for 
Did you mean: 

USB 3 problem using large (UASP) ext hard drive on Prime Z370-A MB headers

Level 7
Asking for inspiration before I tear it all apart or go mad:

Windows 10 pro desktop V1809. All patched up to date. A clean install 6 months ago.

Connected a new Seagate 6TB USB3 external desktop hard drive to do a backup.
Disk Drive is detected correctly (Seagate Expansion Desk SCSI Disk Device in Device manager),
USB attached SCSI (UAS)Protocol Mass storage controller (microsoft) is loaded in storage controllers
After a bit gets given a drive letter but notably the Seagate name above and icon do NOT show up in explorer
Device vanishes from Explorer, repeats every 20 secs
Disk manager shows the device coming and going very rapidly - took a snapshot: 6TB RAW HDD. Wont stay up long enough to reformat . .

OK so the new Drive is stuffed . . ah well it happens . . shall I send it back ?

Connect to W7 pro laptop USB2 All is well - it was properly formatted and working just as expected
Return to the Desktop PC's USB3 - the same, try the adjacent USB3 socket . .the same ...

Remove and reinstall every USB and Hub driver /controller - many restarts - no change.

NOW it gets interesting.
The two USB3 sockets I tried were both in a 'drive tray' module 2xUSB unit connected by cable to the front edge of the MB header (the one below the graphics card). Neither worked

The Two Corsair case-top USB3's connected to the bottom of the MB header DO work - Drive connects and mounts immediately and identifies by name
And connecting to a Fresco /VLI chipset PCIe USB3 card also works fine. It's ONLY connection to the 'side header' that doesn't work
and yet that header supports e.g. USB3 64GB (not UAS) high speed pen drives (ASSSD tested all OK at 240MB/s Read 175MB/s write and thumbnail drives (not UAS) also fine.

The connection to the MB from the front tray USB's is just cables no hub no lights,no nothing. Connector plugged into MB correctly but did it again anyway. It was and is 100% seated correctly and fully in. A right pain to check as its under the graphics card . .

Dig deeper. Both the Z370A 's on- board USB3 headers appear to be native - direct from the Z370 chipset. No driver is needed ( Anyway I had installed and now reinstalled the latest chipset drivers from Asus site). How can the bottom one be fully working and the top one not be working on UASP only?

I believe that for Mass Storage devices the USB record is common to all ports so I havn't tried hacking port records etc. as that may end worse than now.

As you will have guessed I have an 'extra' 9 USB 3.1 v1 sockets (7 on the Fresco /VLI PCIe card) around the unit with about half actually in use. (That's in addition to the MB back panel and case top sockets so just using another USB3 socket is entirely possible 😉
It can't logically be 'too many devices' as moving (not removing) one of the devices makes it work. I havn't yet tried swapping the Board Header cables round as I hate USB3 headers in awkward places anyway and there's a lot of cable threading for both and I can't easily believe BOTH the cables from the side header both failed- while both still support USB3 flash drives etc.

So the question is: What the @@@@ have I missed ????